Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-40353

Wrong redirection from course groups page

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.3.7, 2.4.4, 2.5
    • Fix Version/s: 2.3.8, 2.4.5, 2.5.1
    • Component/s: Groups
    • Labels:
    • Testing Instructions:
      1. Login as manager/admin
      2. Open Course Administration -> User -> Groups
      3. In another window logout and login as student (or user who is enrolled in the course but can not manage groups)
      4. Return to the first window and refresh the page or click 'Add group'
      5. Make sure proper capability error is displayed
      Show
      Login as manager/admin Open Course Administration -> User -> Groups In another window logout and login as student (or user who is enrolled in the course but can not manage groups) Return to the first window and refresh the page or click 'Add group' Make sure proper capability error is displayed
    • Affected Branches:
      MOODLE_23_STABLE, MOODLE_24_STABLE, MOODLE_25_STABLE
    • Fixed Branches:
      MOODLE_23_STABLE, MOODLE_24_STABLE, MOODLE_25_STABLE
    • Pull Master Branch:
      wip-MDL-40353-master

      Description

      Not a major (hard to reproduce) but still

      Inside the course I selected:
      Course Administration -> Users -> Groups
      then in another window I logged in as student and forgot about it.
      I returned to the first window and tried to click 'Add group' (or any button, or just refresh page), received an error with text "Array" and redirection to http://localhost/course/view.php, which does not exist because my site is installed in a subfolder.

        Gliffy Diagrams

          Attachments

            Activity

            marina Marina Glancy added a comment -

            I did not correct the redirection url, I've just changed the capability check to the standard call to require_capability()

            stronk7 Eloy Lafuente (stronk7) added a comment -

            The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week.

            TIA and ciao

            damyon Damyon Wiese added a comment -

            Thanks Marina, integrated to 23, 24, 25 and master.

            andyjdavis Andrew Davis added a comment -

            Works as described. Passing.

            damyon Damyon Wiese added a comment -

            This issue is fixed! Hurray! Hurray!
            Your issue is fixed, what a wonderful day!

            Cheers, Damyon


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  8/Jul/13