Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-40490

Database connection error MS SQL

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.6
    • Fix Version/s: 2.6
    • Component/s: Database SQL/XMLDB
    • Labels:
      None
    • Testing Instructions:
      Hide

      Prerequisite

      • This test needs to be run on an ms sql database with the mssql driver.

      Testing

      1. Do a fresh web based install of the master branch.
      2. Make sure that when choosing the database driver, to select SQL * Server FreeTDS (native/mssql)
      3. With the database settings try:
        • One installation with "Database port" left blank.
        • One installation with "Database port" set to the default port (1466 on the moodle server here, but 1433 by default).

      Make sure that each installation proceeds with no database connection error occurring when your settings are correct

      Show
      Prerequisite This test needs to be run on an ms sql database with the mssql driver. Testing Do a fresh web based install of the master branch. Make sure that when choosing the database driver, to select SQL * Server FreeTDS (native/mssql) With the database settings try: One installation with "Database port" left blank. One installation with "Database port" set to the default port (1466 on the moodle server here, but 1433 by default). Make sure that each installation proceeds with no database connection error occurring when your settings are correct
    • Affected Branches:
      MOODLE_26_STABLE
    • Fixed Branches:
      MOODLE_26_STABLE
    • Pull from Repository:
    • Pull Master Branch:
      wip-MDL-40490-master

      Description

      Doing a fresh install of moodle master with MSSQL will result in a Database connection error.
      The addition of a database port and unix socket on the configuration page, means that the settings are now set with no information and the dbhost gets a colon appended with no port settings. This will cause the connection error.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              abgreeve Adrian Greeve
              Reporter:
              abgreeve Adrian Greeve
              Peer reviewer:
              Petr Skoda
              Integrator:
              Damyon Wiese
              Tester:
              Michael de Raadt
              Participants:
              Component watchers:
              Andrew Nicols, Jun Pataleta, Michael Hawkins, Shamim Rezaie, Simey Lameze
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Fix Release Date:
                18/Nov/13