Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-40514

Theme settings don't show up when in a new admin_category except on Admin Pages

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 2.5
    • Fix Version/s: None
    • Component/s: Administration, Themes
    • Labels:
      None
    • Affected Branches:
      MOODLE_25_STABLE

      Description

      I have created a new theme (Essential) that has a large amount of custom settings involved. Too many to fit onto one page.

      To work around this I have created a series of separate admin_settingpage's inside a new custom admin_category that sits under the existing "Themes" category in the admin menu. This is where things get screwy.

      This new Category and its subsequent pages will only show up when viewing administration screens. If I am on any other page (homepage, category, course, etc) it will not display the category at all.

      I am 85% certain isnot a theme issue as it shows up on administration pages. there is no code I have added that should be limiting its visibility.

        Attachments

          Activity

            People

            Assignee:
            skodak Petr Skoda
            Reporter:
            trogdor Julian Ridden
            Participants:
            Component watchers:
            Andrew Lyons, Dongsheng Cai, Huong Nguyen, Jun Pataleta, Michael Hawkins, Shamim Rezaie, Simey Lameze, Bas Brands
            Votes:
            1 Vote for this issue
            Watchers:
            4 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: