Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-40679

Add zlib as a recommended component to environment.xml (for 2.6 and up)

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.5
    • Fix Version/s: 2.6
    • Component/s: Installation
    • Labels:

      Description

      In MDL-40618 I am using gzcompress if zlib is available. It's also currently used in minify, TCPDF if available. It appears required by lib/phpexcel/PHPExcel/Reader/Gnumeric.php.

      These places would make zlib as recommends. Eloy also said he is experimenting with gzcompress in other issues. I don't know which at the time of reporting this issue.

      I would have thought most installs have zlib enabled, so it would be good to inform users that having zlib does provide benefits to their installation.

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  18/Nov/13