Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-4074

Course and subcategories visibility

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Cannot Reproduce
    • Affects Version/s: 1.5.2
    • Fix Version/s: None
    • Component/s: Course
    • Labels:
      None
    • Environment:
      All
    • Affected Branches:
      MOODLE_15_STABLE

      Description

      When a category is set to invisible, the subcategories and their courses are not. Even if they're not directly available by the menu, they are by typing www.example.com/courses/index.php?id=32.

        Gliffy Diagrams

          Attachments

            Activity

            dougiamas Martin Dougiamas added a comment -

            From Guillaume Gautreau (gautreau at ensg.ign.fr) Thursday, 15 September 2005, 03:38 PM:

            Patch :

            http://ghusse.free.fr/patch/visibility.patch

            Now :

            • A course created in an hidden category is automatically set to hidden
            • A course can not be set as visible in an invisible category
            • A course moved to a invisible category is set to invisible
            • When a category is set to invisible, all the subcategories and all the courses under are set to invisible
            • When a course is set to visible, all the parent categories are set to visible but not their courses.

            From Patrick Li (patrick at catalyst.net.nz) Tuesday, 13 December 2005, 12:08 PM:

            This issue is fixed in both stable and development brach. But a different approach is applied.

            From (andreev.artem at gmail.com) Wednesday, 22 February 2006, 05:54 PM:

            Can you read discussion http://moodle.org/mod/forum/discuss.php?d=36739#185246 ?

            From Martin Dougiamas (martin at moodle.com) Thursday, 6 April 2006, 01:25 PM:

            I've undone this patch in 1.5.3+ because several big sites depended on it. It needs to be addressed properly in 1.6 or later, perhaps with an option.

            timhunt Tim Hunt added a comment -

            An option for this has indeed been introduced in one of the versions since this bug was filed.


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: