Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 1.5.2
    • Fix Version/s: None
    • Component/s: Quiz
    • Labels:
      None
    • Environment:
      All
    • Affected Branches:
      MOODLE_15_STABLE
    • Rank:
      7661

      Description

      It rise error A required parameter (course) was missing.

      In HEAD it still works.

        Activity

        Martin Dougiamas added a comment -

        From Dmitry Pupinin (dlnsk at nspu.ru) Friday, 30 September 2005, 04:54 PM:

        Bug fixed!

        Index: mod/quiz/editlib.php

        ===================================================================

        RCS file: /cvsroot/moodle/moodle/mod/quiz/editlib.php,v

        retrieving revision 1.8.2.7

        diff -u -r1.8.2.7 editlib.php

        — mod/quiz/editlib.php 17 Sep 2005 12:00:20 -0000 1.8.2.7

        +++ mod/quiz/editlib.php 30 Sep 2005 08:44:58 -0000

        @@ -509,7 +511,7 @@

        helpbutton(import, $strimportquestions, quiz);

        echo ' / ';

        }

        • echo '<a href=export.php?category='.$category->id.'>'.$strexportquestions.'</a>';

        + echo <a href=\export.php?category={$category->id}&courseid={$course->id}\>$strexportquestions</a>;

        helpbutton(export, $strexportquestions, quiz);

        echo '</font></td></tr>';

        Index: mod/quiz/export.php

        ===================================================================

        RCS file: /cvsroot/moodle/moodle/mod/quiz/export.php,v

        retrieving revision 1.16.2.2

        diff -u -r1.16.2.2 export.php

        — mod/quiz/export.php 16 Sep 2005 10:02:42 -0000 1.16.2.2

        +++ mod/quiz/export.php 30 Sep 2005 08:46:46 -0000

        @@ -5,7 +5,7 @@

        require_once(locallib.php);

        require_variable($category);

        • $courseid = required_param('course',PARAM_INT);

        + $courseid = required_param('courseid',PARAM_INT);

        optional_variable($format);

        From Howard Miller (howard.miller at udcf.gla.ac.uk) Friday, 30 September 2005, 05:04 PM:

        I'm confused - I couldn't reproduce this problem. Have you submitted this patch recently?

        From Howard Miller (howard.miller at udcf.gla.ac.uk) Friday, 30 September 2005, 05:37 PM:

        I think I fixed this. Are you running 1.5.2+??

        From Dmitry Pupinin (dlnsk at nspu.ru) Saturday, 1 October 2005, 10:39 PM:

        Yes. I'm using 1.5.2+

        I was detect ths problem recently.

        This problem couldn't reproduce if register_globals is On in php.ini

        I think so...

        From Robert Collazo (robert.collazo at scfl.us) Thursday, 13 October 2005, 04:35 AM:

        Applied this listed patch and export of questions still doesn't work. Export.php is v1.16.2.2 and editlib.php is v1.8.2.7

        From Howard Miller (howard.miller at udcf.gla.ac.uk) Thursday, 13 October 2005, 05:03 AM:

        weird this..... I'll investigate thoroughly tomorrow

        From Howard Miller (howard.miller at udcf.gla.ac.uk) Thursday, 13 October 2005, 06:42 PM:

        I'm at a loss! I cannot reproduce this bug in 1.5.2+. I have tried on all the systems I have got. I don't think there is anything else I can do, without more information on this. Sorry

        From Robert Collazo (robert.collazo at scfl.us) Thursday, 13 October 2005, 11:24 PM:

        Can you tell me what info you need and I will get it to you? Just email me.

        From Ray Lawrence (ray at howtomoodle.com) Wednesday, 19 October 2005, 07:35 AM:

        Hi Howard,

        I'm still getting this too. Upgraded to the latest 1.5.2+ today (this evening).

        Message is A required parameter (course) was missing.

        I'm running a Moodle evaluation event on Thurs & Friday this week - will be using this feature (as timetabled) on Friday. Anything you can find by ....... tomorrow would be much appreciated.

        Ray

        From Ray Lawrence (ray at howtomoodle.com) Wednesday, 19 October 2005, 07:50 AM:

        Just tried with a completely new install, created some fresh questions....same problem.

        I noticed that the Moodle version number (1.5.2 + (2005060223)) appears the same as the version I upgraded from earlier - they are being updated nightly aren't they?

        Ray

        From Howard Miller (howard.miller at udcf.gla.ac.uk) Wednesday, 19 October 2005, 01:24 PM:

        For some weird reason, I still can't reproduce this. I'll try another clean install of 1.5.2+ later this morning.

        BTW- the version number is not the build data - it;s changed when required, typically when there are significant database structure changes (ie, no going back)

        From Howard Miller (howard.miller at udcf.gla.ac.uk) Wednesday, 19 October 2005, 01:42 PM:

        Mmm... now I see it :-o

        Fixed in CVS

        From Dmitry Pupinin (dlnsk at nspu.ru) Thursday, 20 October 2005, 02:12 PM:

        We should use & instead & in links...

        ...if I fully appreciate moodle standard

        Index: mod/quiz/editlib.php

        ===================================================================

        RCS file: /cvsroot/moodle/moodle/mod/quiz/editlib.php,v

        retrieving revision 1.8.2.8

        diff -u -r1.8.2.8 editlib.php

        — mod/quiz/editlib.php 19 Oct 2005 05:41:44 -0000 1.8.2.8

        +++ mod/quiz/editlib.php 19 Oct 2005 12:12:07 -0000

        @@ -509,7 +511,7 @@

        helpbutton(import, $strimportquestions, quiz);

        echo ' / ';

        }

        • echo <a href=\export.php?category={$category->id}&course={$course->id}\>$strexportquestions</a>;

        + echo <a href=\export.php?category={$category->id}&course={$course->id}\>$strexportquestions</a>;

        helpbutton(export, $strexportquestions, quiz);

        echo '</font></td></tr>';

        From Howard Miller (howard.miller at udcf.gla.ac.uk) Thursday, 20 October 2005, 03:58 PM:

        Whoops.... quite so - fixed!

        From Ray Lawrence (ray at howtomoodle.com) Monday, 24 October 2005, 07:07 PM:

        Cheers! :-D


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: