Moodle
  1. Moodle
  2. MDL-41379

button alignment on course outcome screen is wonky in Clean

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.5.1
    • Fix Version/s: 2.5.3
    • Component/s: Themes
    • Labels:
    • Testing Instructions:
      Hide
      1. Set your theme to Clean.
      2. Enable outcomes on your site. If the new 2.6 outcomes system has been integrated make sure that your site is set to use the old outcomes system.
      3. Create one or more standard outcomes. site admin > grades > outcomes.
      4. Go to a course select course admin > outcomes and TEST that the buttons are visible and even.
      5. Change to Standard theme and TEST as No.4 above.

      Make sure that the page displays nicely. Not like in the attached screenshot.

      Show
      Set your theme to Clean. Enable outcomes on your site. If the new 2.6 outcomes system has been integrated make sure that your site is set to use the old outcomes system. Create one or more standard outcomes. site admin > grades > outcomes. Go to a course select course admin > outcomes and TEST that the buttons are visible and even. Change to Standard theme and TEST as No.4 above. Make sure that the page displays nicely. Not like in the attached screenshot.
    • Affected Branches:
      MOODLE_25_STABLE
    • Fixed Branches:
      MOODLE_25_STABLE
    • Pull Master Branch:
      MDL-41379_outcomes
    • Story Points (Obsolete):
      5
    • Sprint:
      FRONTEND Sprint 6

      Description

      See screenshot

        Gliffy Diagrams

          Issue Links

            Activity

            Hide
            Kris Stokking added a comment -

            Andrew - I think this needs to be reassigned. This screen is for the legacy version of Outcomes, not the new version.

            Show
            Kris Stokking added a comment - Andrew - I think this needs to be reassigned. This screen is for the legacy version of Outcomes, not the new version.
            Hide
            Mary Evans added a comment - - edited

            Just linking to MDL-41175 which is a similar BUG to this, but found in Groups, but nevertheless it's the same Add/Remove buttons misplacement within the page layout .

            Show
            Mary Evans added a comment - - edited Just linking to MDL-41175 which is a similar BUG to this, but found in Groups, but nevertheless it's the same Add/Remove buttons misplacement within the page layout .
            Hide
            Michael de Raadt added a comment -

            Now that MDL-41175 is resolved, is this issue fixed in stable branches, Andrew?

            Show
            Michael de Raadt added a comment - Now that MDL-41175 is resolved, is this issue fixed in stable branches, Andrew?
            Hide
            Andrew Davis added a comment -

            This issue still exists in current master. I'll remove Mark as the assignee for this issue as this is regarding the old rather than the new outcomes system.

            Show
            Andrew Davis added a comment - This issue still exists in current master. I'll remove Mark as the assignee for this issue as this is regarding the old rather than the new outcomes system.
            Hide
            Andrew Davis added a comment -

            Set your theme to Clean. Enable outcomes on your site. If the new 2.6 outcomes system has been integrated make sure that your site is set to use the old outcomes system.

            Create one or more standard outcomes. site admin > grades > outcomes.

            Go to a course. course admin > outcomes.

            Make sure that the page displays nicely. Not like in the attached screenshot.

            Show
            Andrew Davis added a comment - Set your theme to Clean. Enable outcomes on your site. If the new 2.6 outcomes system has been integrated make sure that your site is set to use the old outcomes system. Create one or more standard outcomes. site admin > grades > outcomes. Go to a course. course admin > outcomes. Make sure that the page displays nicely. Not like in the attached screenshot.
            Hide
            Damyon Wiese added a comment -

            Thanks Andrew - the change looks good for clean - but you need to add these css changes to base as well (otherwise the table is no longer centered).

            Show
            Damyon Wiese added a comment - Thanks Andrew - the change looks good for clean - but you need to add these css changes to base as well (otherwise the table is no longer centered).
            Hide
            Damyon Wiese added a comment -

            (Also needs testing instructions on different themes)

            Show
            Damyon Wiese added a comment - (Also needs testing instructions on different themes)
            Hide
            Mary Evans added a comment -

            This may sound as if I am being a little pedantic, but the css is not written correctly it should have a space after the colon also you could have written it like so...
             

            #page-grade-edit-outcome-course .courseoutcomes {
            +    margin: 0 auto;
            +    width: 100%;
            +} 
            

            Show
            Mary Evans added a comment - This may sound as if I am being a little pedantic, but the css is not written correctly it should have a space after the colon also you could have written it like so...   #page-grade-edit-outcome-course .courseoutcomes { + margin: 0 auto; + width: 100%; +}
            Hide
            Mary Evans added a comment -

            @Damyon,

            Surely how it is tested in Clean and in Standard should have nothing to do with the themes surely, as the form is generated the same in all themes or should be. If it isn't then the form needs rewriting in core thus reducing the amount of, what I would call, trivial CSS loading the system. In other words if the buttons are wrong, then obviously they have been created wrongly in the first place.

            Show
            Mary Evans added a comment - @Damyon, Surely how it is tested in Clean and in Standard should have nothing to do with the themes surely, as the form is generated the same in all themes or should be. If it isn't then the form needs rewriting in core thus reducing the amount of, what I would call, trivial CSS loading the system. In other words if the buttons are wrong, then obviously they have been created wrongly in the first place.
            Hide
            Mary Evans added a comment -

            Just adding David Scotson as a watch as this may interest him.

            Show
            Mary Evans added a comment - Just adding David Scotson as a watch as this may interest him.
            Hide
            Andrew Davis added a comment -

            Damyon, I've added the base version.

            Mary, I've fixed up the white space in the CSS.

            On the issue of the amount of css, previously the generated html had some hard coded css in style tags. I've now removed that so that it can be controlled by the themes. The downside of that is that the table is no longer centred without some css which I've now added.

            Show
            Andrew Davis added a comment - Damyon, I've added the base version. Mary, I've fixed up the white space in the CSS. On the issue of the amount of css, previously the generated html had some hard coded css in style tags. I've now removed that so that it can be controlled by the themes. The downside of that is that the table is no longer centred without some css which I've now added.
            Hide
            Andrew Davis added a comment -

            I'm putting this up for integration while its in front of me but if anyone has any ideas for how this could be done better let me know

            Show
            Andrew Davis added a comment - I'm putting this up for integration while its in front of me but if anyone has any ideas for how this could be done better let me know
            Hide
            Dan Poltawski added a comment -

            Does this need backporting to 2.5?

            Show
            Dan Poltawski added a comment - Does this need backporting to 2.5?
            Hide
            Andrew Davis added a comment - - edited

            Added 2.5 version. Apologies for not doing it previously. Slipped my mind.

            Show
            Andrew Davis added a comment - - edited Added 2.5 version. Apologies for not doing it previously. Slipped my mind.
            Hide
            Dan Poltawski added a comment -

            Thanks Andrew - integrated to master and 25

            Show
            Dan Poltawski added a comment - Thanks Andrew - integrated to master and 25
            Hide
            Adrian Greeve added a comment -

            Tested on the 2.5 and master integration branches.
            The buttons do not look like the ones in the screen shot \o/
            Test passed.

            Show
            Adrian Greeve added a comment - Tested on the 2.5 and master integration branches. The buttons do not look like the ones in the screen shot \o/ Test passed.
            Hide
            Eloy Lafuente (stronk7) added a comment -

            Yes, it's happening (somewhere in the French Polynesia, right now). And you did it, raising Moodle to new excellency levels.

            Or, if you prefer, yes, you fixed that boring issue.

            Thanks anyway! Ciao

            Show
            Eloy Lafuente (stronk7) added a comment - Yes, it's happening (somewhere in the French Polynesia, right now). And you did it, raising Moodle to new excellency levels. Or, if you prefer, yes, you fixed that boring issue. Thanks anyway! Ciao

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Agile