Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-41384

Debugging message regarding numsections in course format when upgrading

    XMLWordPrintable

    Details

    • Testing Instructions:
      Hide

      The reported message should not happen any more, so this is just a test for regressions:

      Test 1 (upgrade):

      1. Install the oldest version of 2.2
      2. enable debugging
      3. upgrade to integration version

      Repeat this for 2.5, 2.6 and master through web-interface or CLI. Patches for 2.6 and master are exactly the same so one can be tested via CLI and another with web interface.

      Test 2 (after upgrade).

      1. Create course in topics format, change number of section to something not default.
      2. Create activitiy
      3. Move activity from one section to another
      4. Click "Edit course settings"
      5. Make sure no messages are displayed and the number of sections is correct
      Show
      The reported message should not happen any more, so this is just a test for regressions: Test 1 (upgrade): Install the oldest version of 2.2 enable debugging upgrade to integration version Repeat this for 2.5, 2.6 and master through web-interface or CLI. Patches for 2.6 and master are exactly the same so one can be tested via CLI and another with web interface. Test 2 (after upgrade). Create course in topics format, change number of section to something not default. Create activitiy Move activity from one section to another Click "Edit course settings" Make sure no messages are displayed and the number of sections is correct
    • Affected Branches:
      MOODLE_25_STABLE, MOODLE_26_STABLE, MOODLE_27_STABLE
    • Fixed Branches:
      MOODLE_25_STABLE, MOODLE_26_STABLE
    • Pull Master Branch:
      wip-MDL-41384-master
    • Sprint:
      BACKEND Sprint 9

      Description

      I've looked at the current opened issues but I haven't found anything reported. When upgrading a site with at least 1 course (I don't know without courses) through CLI the following debugging message appears.

      I've reproduced it upgrading:

      • 2.3 to 2.5
      • 2.2 to master (2.6 dev at 22 Aug 2013)

      ++ The option name numsections in course format site is invalid because the field with the same name exists in {course} table ++
      * line 246 of /course/format/lib.php: call to debugging()
      * line 3544 of /lib/adminlib.php: call to format_base->get_course()
      * line 6447 of /lib/adminlib.php: call to admin_setting_sitesettext->get_setting()
      * line 6442 of /lib/adminlib.php: call to admin_apply_default_settings()
      * line 6442 of /lib/adminlib.php: call to admin_apply_default_settings()
      * line 172 of /admin/cli/upgrade.php: call to admin_apply_default_settings()
      

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                7 Vote for this issue
                Watchers:
                8 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  10/Mar/14