Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.5.2
    • Fix Version/s: 2.5.3
    • Component/s: Quiz
    • Labels:
    • Testing Instructions:
      1. Go to the edit quiz page for any quiz.
      2. Check that all the boxes have properly rounded courners in
        • both Edit quiz and Order and paging tabs.
        • both Clean and Standard themes.

      Acutally, I am not at all convinced by how the edit quiz page looks in the Clean theme, but I think that is another bug.

      Show
      Go to the edit quiz page for any quiz. Check that all the boxes have properly rounded courners in both Edit quiz and Order and paging tabs. both Clean and Standard themes. Acutally, I am not at all convinced by how the edit quiz page looks in the Clean theme, but I think that is another bug.
    • Affected Branches:
      MOODLE_25_STABLE
    • Fixed Branches:
      MOODLE_25_STABLE
    • Pull from Repository:
    • Pull Master Branch:

      Description

      The stylesheet uses wrong properties for the border radius:

      border-radius-bottomleft => border-bottom-left-radius
      border-radius-bottomright => border-bottom-right-radius
      border-radius-topleft => border-top-left-radius
      border-radius-topright => border-top-right-radius

        Gliffy Diagrams

          Issue Links

            Activity

            timhunt Tim Hunt added a comment -

            Requesting peer review. If this is OK, I will back-port to stable branches.

            timhunt Tim Hunt added a comment -

            Ah! I think the cause of the mistake is that the old browser-specific property name was like -moz-border-radius-bottomright, and I was not careful enough when I converted that to the standard code.

            rajeshtaneja Rajesh Taneja added a comment -

            Thanks for fixing this Tim,

            Patch looks spot-on.

            Just noting: border-bottom-*-radius property is supported in IE9+, Firefox 4+, Chrome, Safari 5+, and Opera, so meet moodle min. browser criteria, (except ie8)
            I hope that is fine as there is no easy way to get rounded corners in ie8.

            +1 for integration.

            timhunt Tim Hunt added a comment -

            Grr! it looks like I screwed up in my previous commit, and did not find all the mistakes in that CSS file. I have amended it after doing a proper search and fix.

            And submitting for integration, since this was agreen in principle.

            samhemelryk Sam Hemelryk added a comment -

            Thanks Tim this has been integrated now.

            rwijaya Rossiani Wijaya added a comment -

            Hi Tim,

            While testing this for 2.5 and master, I noticed on 'editting quiz' and 'order and paging' page, the page content box's border is inconsistent. The left top and bottom borders are squared corner, while the right top and bottom borders are rounded corner. See attachment.

            Comparing it with current stable version, it has rounded corner for page content.

            Could you please comment on this?

            timhunt Tim Hunt added a comment -

            I think the different left and right corners are intentional. Look at the diff for this change, to see why it was not working in current stable.

            (Note, there is not actually an attachment here.)

            rwijaya Rossiani Wijaya added a comment -

            Attaching screenshot

            timhunt Tim Hunt added a comment -

            Right. I think the square corners are supposed to give a visual cue that this thing is connected to "Page 1".

            poltawski Dan Poltawski added a comment -

            Rosie asked me about this one.. and while this change is fixing those border radius rules, so I suppose should be passed, the whole CSS needs an overhaul.

            Look at how this looks on clean and standard now..

            rwijaya Rossiani Wijaya added a comment -

            Thanks for commenting Dan.

            I created issue to fix the border style in clean theme. MDL-41864.

            I'm passing this issue because this issue is for fixing the rules.

            Testing this for 2.5 and master.

            Test passed.

            samhemelryk Sam Hemelryk added a comment -

            Yarrr me 'arties, good job done. Yer code 'as landed and the weeklies ave been released with your contributions in tow.
            The brethren thank ya for yer 'ard work and if there'd been treasure to ave ya would ave got yer cut.

            Thanks for the effort everyone, another successful weekly release has been rolled.
            Please keep in mind code freeze is just around the corner now, get your new features and improvements in ASAP.

            Many thanks
            Sam


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  11/Nov/13