Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-41853

Backport MDL-38197 (automated course generator)

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 2.5.2
    • Fix Version/s: 2.5.3
    • Component/s: Performance
    • Labels:

      Description

      As discussed, the current 2.5 tool_generator is broken and having the new tool_generator features for testing also in 2.5 can be good so we can compare from 2.5 onwards rather than 2.6.

      (Related with https://github.com/moodlehq/moodle-performance-comparison)

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              Hide
              skodak Petr Skoda added a comment -

              thanks, submitting for itnegration

              Show
              skodak Petr Skoda added a comment - thanks, submitting for itnegration
              Hide
              dmonllao David Monllaó added a comment -

              Raising priority as we need to run the performance comparison tests between 2.5 and 2.6 as soon as possible

              Show
              dmonllao David Monllaó added a comment - Raising priority as we need to run the performance comparison tests between 2.5 and 2.6 as soon as possible
              Hide
              damyon Damyon Wiese added a comment -

              Thanks David, this looks OK to me - I tested it and it works.

              I added a commit to fix the version bump on the stable branch.

              Integrated to 25 only.

              Show
              damyon Damyon Wiese added a comment - Thanks David, this looks OK to me - I tested it and it works. I added a commit to fix the version bump on the stable branch. Integrated to 25 only.
              Hide
              damyon Damyon Wiese added a comment -

              Please note - this is for stables and I have added docs_required for the new cli tool + admin page. Please add the docs for this ASAP.

              Show
              damyon Damyon Wiese added a comment - Please note - this is for stables and I have added docs_required for the new cli tool + admin page. Please add the docs for this ASAP.
              Hide
              dmonllao David Monllaó added a comment -
              Show
              dmonllao David Monllaó added a comment - Removing docs_required http://docs.moodle.org/25/en/Test_course_generator
              Hide
              rwijaya Rossiani Wijaya added a comment -

              This is working as expected.

              Tested for 2.5 only.

              Test passed.

              Show
              rwijaya Rossiani Wijaya added a comment - This is working as expected. Tested for 2.5 only. Test passed.
              Hide
              poltawski Dan Poltawski added a comment -

              You did it!

              Thanks for your contribution, this change has been merged upstream and is now available on your local git mirror and on download sites shortly.

              Show
              poltawski Dan Poltawski added a comment - You did it! Thanks for your contribution, this change has been merged upstream and is now available on your local git mirror and on download sites shortly.

                People

                • Votes:
                  0 Vote for this issue
                  Watchers:
                  5 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    11/Nov/13