Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-4192

Users may register with invalid usernames but may not edit profile

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 1.5.2
    • Fix Version/s: None
    • Component/s: Authentication
    • Labels:
      None
    • Environment:
      All
    • Database:
      PostgreSQL
    • Affected Branches:
      MOODLE_15_STABLE

      Description

      Many of my students registered with names containing spaces or underscores. When I had to reset their lost passwords I could not update their profile on the Edit profile page because Moodle said 'Can only contain alphabetical letters or numbers' about their username. If Moodle allows a username to be created it should also be a valid one to edit.

        Gliffy Diagrams

          Activity

          Hide
          dougiamas Martin Dougiamas added a comment -

          From (penny at catalyst.net.nz) Wednesday, 26 October 2005, 10:32 AM:

          I can't repro this - when I try and sign up with a username with an underscore, I get the alphanumeric error.

          From Reed Law (reedlaw at gmail.com) Tuesday, 1 November 2005, 10:21 AM:

          I have tested it again and I find that it only applies when the authentication type is set to No Authentication. If I create a new user by entering a new username and password I can create it with a space in the name.

          From (penny at catalyst.net.nz) Monday, 12 December 2005, 11:06 AM:

          hah. ok, I can repro now. this should certainly clean usernames, I will fix.

          From (penny at catalyst.net.nz) Monday, 12 December 2005, 11:18 AM:

          Just put a fix into HEAD and 1.5.3+ latest. Please upgrade and let me know how you get on, I will delay closing this bug until then.

          Retroactively, there's not much you can do other than change all the usernames..

          From (penny at catalyst.net.nz) Tuesday, 20 December 2005, 08:23 AM:

          Hi, can you update to latest 1.5.3+ and let me know how you get on? I'd like to close this bug if it's fixed.

          From Reed Law (reedlaw at gmail.com) Tuesday, 20 December 2005, 09:43 AM:

          I'm not planning on upgrading or even using Moodle anymore at this point. The amount of bugs in it have given me a very stressful semester and I wish I knew that it was not mature before I adopted it. I thought a version 1.52 product would be reasonably stable. This was a small bug, but there were many others that caused huge trouble. I'm sorry but I feel at this point I would save more time designing my own solution for this school than continuing to troubleshoot Moodle.

          From (penny at catalyst.net.nz) Tuesday, 20 December 2005, 09:57 AM:

          Wow, I'm really sorry to hear that.

          We're running moodle pretty happily for a number of pretty large installations (40,000 users & 10,000 courses is the largest) on a cluster of machines here, and we have hardly any problems with it.

          To each their own though, thanks for the bug report. I'll close it now.

          Show
          dougiamas Martin Dougiamas added a comment - From (penny at catalyst.net.nz) Wednesday, 26 October 2005, 10:32 AM: I can't repro this - when I try and sign up with a username with an underscore, I get the alphanumeric error. From Reed Law (reedlaw at gmail.com) Tuesday, 1 November 2005, 10:21 AM: I have tested it again and I find that it only applies when the authentication type is set to No Authentication. If I create a new user by entering a new username and password I can create it with a space in the name. From (penny at catalyst.net.nz) Monday, 12 December 2005, 11:06 AM: hah. ok, I can repro now. this should certainly clean usernames, I will fix. From (penny at catalyst.net.nz) Monday, 12 December 2005, 11:18 AM: Just put a fix into HEAD and 1.5.3+ latest. Please upgrade and let me know how you get on, I will delay closing this bug until then. Retroactively, there's not much you can do other than change all the usernames.. From (penny at catalyst.net.nz) Tuesday, 20 December 2005, 08:23 AM: Hi, can you update to latest 1.5.3+ and let me know how you get on? I'd like to close this bug if it's fixed. From Reed Law (reedlaw at gmail.com) Tuesday, 20 December 2005, 09:43 AM: I'm not planning on upgrading or even using Moodle anymore at this point. The amount of bugs in it have given me a very stressful semester and I wish I knew that it was not mature before I adopted it. I thought a version 1.52 product would be reasonably stable. This was a small bug, but there were many others that caused huge trouble. I'm sorry but I feel at this point I would save more time designing my own solution for this school than continuing to troubleshoot Moodle. From (penny at catalyst.net.nz) Tuesday, 20 December 2005, 09:57 AM: Wow, I'm really sorry to hear that. We're running moodle pretty happily for a number of pretty large installations (40,000 users & 10,000 courses is the largest) on a cluster of machines here, and we have hardly any problems with it. To each their own though, thanks for the bug report. I'll close it now.

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: