Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-42010

Error in Assignment (2.2) upgrade helper

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open
    • Priority: Minor
    • Resolution: Unresolved
    • Affects Version/s: 2.5.1, 2.7
    • Fix Version/s: None
    • Component/s: Assignment (2.2)
    • Labels:
    • Affected Branches:
      MOODLE_25_STABLE, MOODLE_27_STABLE

      Description

      Receive an error message

      Coding error detected, it must be fixed by a programmer: moodle_database::get_in_or_equal() does not accept empty arrays

      Debug info:
      Error code: codingerror
      Stack trace:
      line 662 of \lib\dml\moodle_database.php: coding_exception thrown
      line 147 of \admin\tool\assignmentupgrade\locallib.php: call to moodle_database->get_in_or_equal()
      line 64 of \admin\tool\assignmentupgrade\upgradableassignmentstable.php: call to tool_assignmentupgrade_any_upgradable_assignments()
      line 44 of \admin\tool\assignmentupgrade\listnotupgraded.php: call to tool_assignmentupgrade_assignments_table->__construct()
      Output buffer:

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              sallison Simon Allison
              Participants:
              Component watchers:
              Adrian Greeve, Jake Dallimore, Mathew May, Mihail Geshoski, Peter Dias
            • Votes:
              4 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated: