Moodle
  1. Moodle
  2. MDL-42209

Wrong Icon when restoring course backups

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.4.6, 2.5
    • Fix Version/s: 2.4.7, 2.5.3
    • Component/s: Backup
    • Labels:

      Description

      When restoring a moodle 2 backup (that contains no user information) the wrong icon is displayed.

        Gliffy Diagrams

          Activity

          Hide
          Dan Poltawski added a comment -

          Requesting peer review for Filip.

          Show
          Dan Poltawski added a comment - Requesting peer review for Filip.
          Hide
          Mark Nelson added a comment -

          Thanks Filip, I will replicate this issue tomorrow and then review your patch. Thanks again for your contribution.

          Show
          Mark Nelson added a comment - Thanks Filip, I will replicate this issue tomorrow and then review your patch. Thanks again for your contribution.
          Hide
          Mark Nelson added a comment -

          Also, please let me know if I got the testing instructions correct.

          Show
          Mark Nelson added a comment - Also, please let me know if I got the testing instructions correct.
          Hide
          Mark Nelson added a comment -

          I was able to replicate the issue and applied the patch and it works perfectly. Thanks Filip. However, before I submit this to integration could you please change the commit message to include the tracker issue number and the component? For example - "MDL-42209 backup: fixed wrong icon being displayed when restoring course".

          Cheers!

          Show
          Mark Nelson added a comment - I was able to replicate the issue and applied the patch and it works perfectly. Thanks Filip. However, before I submit this to integration could you please change the commit message to include the tracker issue number and the component? For example - " MDL-42209 backup: fixed wrong icon being displayed when restoring course". Cheers!
          Hide
          Mark Nelson added a comment -

          Also, note to integrators, this is an issue in 2.4 as well so should be backported.

          Show
          Mark Nelson added a comment - Also, note to integrators, this is an issue in 2.4 as well so should be backported.
          Hide
          Dan Poltawski added a comment -

          Thanks Filip, integrated to master, 25 and 24.

          Show
          Dan Poltawski added a comment - Thanks Filip, integrated to master, 25 and 24.
          Hide
          Filip Benčo added a comment -

          Ouch, sorry for not changing the commit message. I was away from internet for a bit.
          I am glad I helped.

          Show
          Filip Benčo added a comment - Ouch, sorry for not changing the commit message. I was away from internet for a bit. I am glad I helped.
          Hide
          Damyon Wiese added a comment -

          Stealing this test - hope you don't mind!

          Show
          Damyon Wiese added a comment - Stealing this test - hope you don't mind!
          Hide
          Damyon Wiese added a comment -

          Tested on 24, 25 and master. Works as described. Thanks!

          Show
          Damyon Wiese added a comment - Tested on 24, 25 and master. Works as described. Thanks!
          Hide
          Dan Poltawski added a comment -

          Hurrah! Thanks for your contribution - this fix is part of Moodle.

          Show
          Dan Poltawski added a comment - Hurrah! Thanks for your contribution - this fix is part of Moodle.

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: