Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.4.6, 2.5.2
    • Fix Version/s: 2.4.7, 2.5.3, 2.6
    • Component/s: Questions
    • Labels:
    • Testing Instructions:

      Almost all the changes are in comments. This tests that the other changes have not caused a regression:

      0. Unit tests have already been run.

      1. Create a numerical question. Check that the unit handing option "Units are optional. If a unit is entered, it is used to convert the response to Unit 1 before grading." does not contain a typo.

      2. Create an essay question using the HTML editor, preview it, and ensure you can input a response and it is saved.

      3. Go to a quiz with student attempts, and make sure you can view the statistics report. Click through to a question and make sure the response analysis table is shown with no errors.

      Show
      Almost all the changes are in comments. This tests that the other changes have not caused a regression: 0. Unit tests have already been run. 1. Create a numerical question. Check that the unit handing option "Units are optional. If a unit is entered, it is used to convert the response to Unit 1 before grading." does not contain a typo. 2. Create an essay question using the HTML editor, preview it, and ensure you can input a response and it is saved. 3. Go to a quiz with student attempts, and make sure you can view the statistics report. Click through to a question and make sure the response analysis table is shown with no errors.
    • Affected Branches:
      MOODLE_24_STABLE, MOODLE_25_STABLE
    • Fixed Branches:
      MOODLE_24_STABLE, MOODLE_25_STABLE, MOODLE_26_STABLE
    • Pull from Repository:
    • Pull Master Branch:

      Description

      A user reported a typo to me in the numerical question type. One string contained 'reponse' not 'response'.

      So, I searched the whole code for 'reponse' and found 21 hits in our code, mostly in comments.

      I am going to fix them all.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              timhunt Tim Hunt added a comment -

              Ready for peer review.

              timhunt Tim Hunt added a comment -

              Note, the patches for the stable branches are not quite the same as for master. The differences are only in comments.

              quen Sam Marshall added a comment -

              Had a look through these, most are comments, the other ones appear correct (given that I know you did them with search/replace).

              skodak Petr Skoda added a comment -

              eh, why would you want to search replace stuff in 3rd party libraries? That sounds very wrong...

              timhunt Tim Hunt added a comment -

              I wouldn't want to, and I didn't.

              skodak Petr Skoda added a comment -

              you did modify the CAS client

              timhunt Tim Hunt added a comment -

              Ah, so how am I meant to know that auth/cas/CAS/CAS/client.php is third-party code. Why isn't it in the lib folder?

              Hopefully the integrators can amend the commit when they get to it. Only the 2.5 branch is affected. (I doubt we will upgrade the lib there, so it is not a big deal.)

              skodak Petr Skoda added a comment -

              Of course you are supposed to know it if you modify it, there is nothing wrong with putting CAS lib in auth/cas if it is not used from anywhere else in core. Next time just look into the file you modifying and see the file header with copyright and version info.

              marina Marina Glancy added a comment -

              Thanks Tim, integrated in 2.4, 2.5 and master.

              Note that I changed your commit message because you made a typo there

              dobedobedoh Andrew Nicols added a comment -

              Unit tests run in integration testing: http://integration.moodle.org/job/20.%20Run%20phpunit%20UnitTests%20(master)/

              All other tests pass as expected. Good typo fixes

              poltawski Dan Poltawski added a comment -

              Hurrah! Thanks for your contribution - this fix is part of Moodle.


                People

                • Votes:
                  0 Vote for this issue
                  Watchers:
                  4 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    11/Nov/13