Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-42521

Feedback does not show line graphs in Clean theme

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.5.2
    • Fix Version/s: 2.5.3, 2.6
    • Component/s: Feedback, Themes
    • Labels:
    • Testing Instructions:
      Hide
      1. Enable the feedback module going to the admin tree -> plugins -> activity modules -> Manage activities
      2. Go to a course and add a Feedback activity and then view the activity
      3. Add a "Multiple choice" question with two or more options
      4. Add a "Multiple choice (rated)" question with two or more options
      5. Do some submits to these questions
      6. Go to the "Analysis" page
      7. The image bars should now shown as expected
      Show
      Enable the feedback module going to the admin tree -> plugins -> activity modules -> Manage activities Go to a course and add a Feedback activity and then view the activity Add a "Multiple choice" question with two or more options Add a "Multiple choice (rated)" question with two or more options Do some submits to these questions Go to the "Analysis" page The image bars should now shown as expected
    • Affected Branches:
      MOODLE_25_STABLE
    • Fixed Branches:
      MOODLE_25_STABLE, MOODLE_26_STABLE
    • Pull from Repository:
    • Pull Master Branch:
      MDL-42521_master

      Description

      Hi,

      setting up a feedback for my workshop I found block graphs but no line graphs. In the feedback forum https://moodle.org/mod/forum/discuss.php?d=239168 I found a hint that the problem comes with the clean theme.

      Would you please fix the problem?

      Best wishes, Ralf

        Gliffy Diagrams

          Attachments

          1. Clean.jpg
            Clean.jpg
            38 kB
          2. feedback-clean-26.png
            feedback-clean-26.png
            66 kB
          3. feedback-clean-42512-a.png
            feedback-clean-42512-a.png
            85 kB
          4. feedback-clean-42512-b.png
            feedback-clean-42512-b.png
            111 kB
          5. Standard.jpg
            Standard.jpg
            42 kB

            Activity

            Hide
            salvetore Michael de Raadt added a comment - - edited

            Thanks for reporting that, Ralf.

            I was able to replicate the problem.

            It looks to be a problem isolated to the Clean theme. It works, but oddly, in Bootstap base.

            Show
            salvetore Michael de Raadt added a comment - - edited Thanks for reporting that, Ralf. I was able to replicate the problem. It looks to be a problem isolated to the Clean theme. It works, but oddly, in Bootstap base.
            Hide
            krause Ralf Krause added a comment -

            Hi Michael,

            from a productive feedback in Moodle 2.5.2 I got this screenshot. I restored the course with its anonymized users on my test server with Moodle 2.6beta (20131025).

            In the current Moodle 2.5.2 and Moodle 2.6 the feedback shows boxes instead of lines.

            Best wishes, Ralf

            Show
            krause Ralf Krause added a comment - Hi Michael, from a productive feedback in Moodle 2.5.2 I got this screenshot. I restored the course with its anonymized users on my test server with Moodle 2.6beta (20131025). In the current Moodle 2.5.2 and Moodle 2.6 the feedback shows boxes instead of lines. Best wishes, Ralf
            Hide
            krause Ralf Krause added a comment -

            I did some tests with the source inspector in my Safari browser. I 'm looking for the code of the big blue graph.

            At the bottom left side you can see the source code for the blue graph and at the bottom right side you can see some css for it. (feedback-clean-42512-a.png)

            If I switch off the auto height then the box graphs change to line graphs with the height of 5 pixels. (feedback-clean-42512-b.png)

            I changed nothing else. I tried to switch on and off the auto hide and I could reproduce everything.

            Show
            krause Ralf Krause added a comment - I did some tests with the source inspector in my Safari browser. I 'm looking for the code of the big blue graph. At the bottom left side you can see the source code for the blue graph and at the bottom right side you can see some css for it. (feedback-clean-42512-a.png) If I switch off the auto height then the box graphs change to line graphs with the height of 5 pixels. (feedback-clean-42512-b.png) I changed nothing else. I tried to switch on and off the auto hide and I could reproduce everything.
            Hide
            grabs Andreas Grabs added a comment -

            Hi Ralf,
            thank you for reporting that!
            I am hoping I solved this in the way you want.
            Best regards
            Andreas

            Show
            grabs Andreas Grabs added a comment - Hi Ralf, thank you for reporting that! I am hoping I solved this in the way you want. Best regards Andreas
            Hide
            damyon Damyon Wiese added a comment -

            Thanks Andreas,

            Integrated to master and 25.

            One thing to note - is that the styles in mod/*/styles.css should really be prefixed with the pagename they are applied on:
            e.g. #page-mod-feedback-analysis

            these styles are included on every page and "div img.feedback_bar_image" for example may accidentally collide with some other page (even though it seems unlikely).

            The rest of the styles are already unprefixed and this one seems unlikely to collide so I haven't required it for this issue, but please follow up and make them all more specific.

            Thanks, Damyon

            Show
            damyon Damyon Wiese added a comment - Thanks Andreas, Integrated to master and 25. One thing to note - is that the styles in mod/*/styles.css should really be prefixed with the pagename they are applied on: e.g. #page-mod-feedback-analysis these styles are included on every page and "div img.feedback_bar_image" for example may accidentally collide with some other page (even though it seems unlikely). The rest of the styles are already unprefixed and this one seems unlikely to collide so I haven't required it for this issue, but please follow up and make them all more specific. Thanks, Damyon
            Hide
            dmonllao David Monllaó added a comment -

            Hi Andreas, I marked you as assignee, feel free to change it if you are not.

            Show
            dmonllao David Monllaó added a comment - Hi Andreas, I marked you as assignee, feel free to change it if you are not.
            Hide
            grabs Andreas Grabs added a comment -

            Hi Damyon,
            thank you for clarify this. Shall I create a separate issue for the css class names?
            I would change all of them in one step.
            Andreas

            Show
            grabs Andreas Grabs added a comment - Hi Damyon, thank you for clarify this. Shall I create a separate issue for the css class names? I would change all of them in one step. Andreas
            Hide
            damyon Damyon Wiese added a comment -

            Yes - please do it in a separate issue. Thanks!

            Show
            damyon Damyon Wiese added a comment - Yes - please do it in a separate issue. Thanks!
            Hide
            dmonllao David Monllaó added a comment -

            Thanks, it passes.

            Show
            dmonllao David Monllaó added a comment - Thanks, it passes.
            Hide
            damyon Damyon Wiese added a comment -

            Here lies 52 bugs.
            All fixed or swept under a rug.
            If they come back one day,
            To our dismay,
            We all will feel quite un-smug.

            Thanks for the reporting/fixing/testing on this issue. It has been sent upstream.

            Show
            damyon Damyon Wiese added a comment - Here lies 52 bugs. All fixed or swept under a rug. If they come back one day, To our dismay, We all will feel quite un-smug. Thanks for the reporting/fixing/testing on this issue. It has been sent upstream.

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  11/Nov/13