Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-42605

Flickr repository cannot add a photo to a set on export

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.6
    • Fix Version/s: 2.4.7, 2.5.3
    • Component/s: Portfolio
    • Labels:
    • Testing Instructions:
      Hide

      Pre-requisites

      • A Flickr account
      • Some "Sets" in your Flickr account

      Test 1

      1. Enable the Flickr Portfolio
      2. Create a forum post with an image as "attachment"
      3. Export the image to Flickr
      4. On the export settings page, do not select any "Set" to export to.
      5. Make sure:
        • The file has been uploaded
        • The file is not in a set
        • You didn't see any error/notice (check logs too)

      Test 2

      1. Export the picture again
      2. This time, select a "Set" on the export settings page
      3. Make sure:
        • The file has been uploaded
        • The file is in the chosen set
        • You didn't see any error/notice (check logs too)

      Test the linked QA test.

      Show
      Pre-requisites A Flickr account Some "Sets" in your Flickr account Test 1 Enable the Flickr Portfolio Create a forum post with an image as "attachment" Export the image to Flickr On the export settings page, do not select any "Set" to export to. Make sure : The file has been uploaded The file is not in a set You didn't see any error/notice (check logs too) Test 2 Export the picture again This time, select a "Set" on the export settings page Make sure : The file has been uploaded The file is in the chosen set You didn't see any error/notice (check logs too) Test the linked QA test.
    • Affected Branches:
      MOODLE_26_STABLE
    • Fixed Branches:
      MOODLE_24_STABLE, MOODLE_25_STABLE
    • Pull from Repository:
    • Pull Master Branch:
      MDL-42605-master

      Description

      This issue relates to MDLQA-5869.

      This test is a partial fail/pass. The image attached to a forum post does export to box.net, flickr and picasa. The post is also exported to box.net. There were 2 idiosyncracies.

      1. The 'Export to portfolio' link located bottom right of forum post only provides option to export to box.net. No option for flickr or picasa. There is however the option to export the image to box.net, flickr and picasa via the small icon located next to the said image. This may (not) be the intended behaviour? I'm supposing because forum post can't be exported to flickr and picasa this explains why they're not in one of the drop menus?

      2. When the forum image attachment is exported to flickr, debugging says:
      Notice: Undefined index: photoid in /home/xyz/public_html/portfolio/flickr/lib.php on line 69

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                fred Frédéric Massart
                Reporter:
                chadsta Chad Outten
                Integrator:
                Damyon Wiese
                Tester:
                Damyon Wiese
                Participants:
                Component watchers:
                Amaia Anabitarte, Carlos Escobedo, Ferran Recio, Sara Arjona (@sarjona), Víctor Déniz Falcón
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  11/Nov/13