Details

    • Type: Sub-task
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 2.4.6, 2.5.2, 2.6
    • Fix Version/s: 2.4.7, 2.5.3, 2.6
    • Component/s: Portfolio
    • Labels:
    • Testing Instructions:
      Hide
      1. Do not upgrade!
      2. Enable the portfolios and configure Box.net
      3. Upgrade
        • Make sure the admin received an email about the new API
        • You should be able to visit a forum without seeing an obscure error (MDL-42741)
        • The entry in mdl_portfolio_instance for Box.net should be set to visible 0.
      4. Configure Box.net with the new settings (OAuth)
      5. Create a forum post, with an image included and an attachment
      6. Export the attachment to Box.net, make sure it worked
      7. Export the whole post to Box.net, make sure it worked
      8. Test the export settings (create a new folder, export to specified folder)
        • Confirm it works

      Test 2

      This test only applies once, not to all supported versions.

      1. Install an old 2.4 (before this patch)
      2. Set up your boxnet portfolio (enable and visible, set api key)
      3. Upgrade to the latest 2.4
      4. Make sure the admin received an email
      5. Set up your portfolio with random client ID and secret
      6. Upgrade to the latest 2.5
      7. Make sure the admin didn't receive any email
      8. Upgrade to the latest 2.6
      9. Make sure the admin didn't receive any email
      Show
      Do not upgrade! Enable the portfolios and configure Box.net Upgrade Make sure the admin received an email about the new API You should be able to visit a forum without seeing an obscure error ( MDL-42741 ) The entry in mdl_portfolio_instance for Box.net should be set to visible 0. Configure Box.net with the new settings (OAuth) Create a forum post, with an image included and an attachment Export the attachment to Box.net, make sure it worked Export the whole post to Box.net, make sure it worked Test the export settings (create a new folder, export to specified folder) Confirm it works Test 2 This test only applies once, not to all supported versions. Install an old 2.4 (before this patch) Set up your boxnet portfolio (enable and visible, set api key) Upgrade to the latest 2.4 Make sure the admin received an email Set up your portfolio with random client ID and secret Upgrade to the latest 2.5 Make sure the admin didn't receive any email Upgrade to the latest 2.6 Make sure the admin didn't receive any email
    • Affected Branches:
      MOODLE_24_STABLE, MOODLE_25_STABLE, MOODLE_26_STABLE
    • Fixed Branches:
      MOODLE_24_STABLE, MOODLE_25_STABLE, MOODLE_26_STABLE
    • Pull from Repository:
    • Pull Master Branch:
      MDL-42668-master

      Description

      Update portfolio_boxnet to use API v2

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                fred Frédéric Massart
                Reporter:
                fred Frédéric Massart
                Peer reviewer:
                Dan Poltawski
                Integrator:
                Damyon Wiese
                Tester:
                Damyon Wiese
                Participants:
                Component watchers:
                Amaia Anabitarte, Carlos Escobedo, Ferran Recio, Sara Arjona (@sarjona), Víctor Déniz Falcón
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  11/Nov/13