Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-42697

Regression: Docked blocks looking awful

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 2.4.6
    • Fix Version/s: 2.4.7, 2.5.3, 2.6
    • Component/s: Themes
    • Labels:
    • Testing Instructions:

      You need to test in as many themes as possible, but at least:

      • arialist
      • fusion
      • standard
      • leatherbound
      • a few others with dockable blocks
      • Open a course with lots of sections
      • Dock the Settings (2.4) / Administration (2.5+) block
      • Pop the block out
        • Confirm that the block is shown correctly and the width is pretty normal
      • Resize the window such that the block will be taller than the window*
      • Refresh the page
      • Reopen the block
        • Confirm that the block width hasn't changed
        • Confirm that the scroll bars for the block are at it's edge (and not in the middle
      Show
      You need to test in as many themes as possible, but at least: arialist fusion standard leatherbound a few others with dockable blocks Open a course with lots of sections Dock the Settings (2.4) / Administration (2.5+) block Pop the block out Confirm that the block is shown correctly and the width is pretty normal Resize the window such that the block will be taller than the window* Refresh the page Reopen the block Confirm that the block width hasn't changed Confirm that the scroll bars for the block are at it's edge (and not in the middle
    • Affected Branches:
      MOODLE_24_STABLE
    • Fixed Branches:
      MOODLE_24_STABLE, MOODLE_25_STABLE, MOODLE_26_STABLE
    • Pull Master Branch:
      MDL-42697-master

      Description

      Dan noticed this bug with docked blocks just now on a non-Clean theme

      https://dl.dropboxusercontent.com/u/5403781/Screen%20Shot%202013-11-05%20at%2000.24.59.png

      Looks pretty bad, can someone from FRONTEND test and clarify the issue here?

        Gliffy Diagrams

          Attachments

          1. chrome-fusion-2.4-dock.png
            chrome-fusion-2.4-dock.png
            267 kB
          2. chrome-fusion-2.5-dock.png
            chrome-fusion-2.5-dock.png
            338 kB
          3. chrome-fusion-2.6-dock_40975.png
            chrome-fusion-2.6-dock_40975.png
            311 kB
          4. chrome-fusion-2.6-dock.png
            chrome-fusion-2.6-dock.png
            345 kB
          5. firefox-fusion-2.4-dock.png
            firefox-fusion-2.4-dock.png
            274 kB
          6. firefox-fusion-2.5-dock.png
            firefox-fusion-2.5-dock.png
            273 kB
          7. firefox-fusion-2.6-dock_40975.png
            firefox-fusion-2.6-dock_40975.png
            293 kB
          8. firefox-fusion-2.6-dock.png
            firefox-fusion-2.6-dock.png
            286 kB
          9. overlay-banner-covers-block-title.png
            overlay-banner-covers-block-title.png
            20 kB
          10. safari-fusion-2.4-dock.png
            safari-fusion-2.4-dock.png
            259 kB
          11. safari-fusion-2.5-dock.png
            safari-fusion-2.5-dock.png
            260 kB
          12. safari-fusion-2.6-dock_40975.png
            safari-fusion-2.6-dock_40975.png
            268 kB
          13. safari-fusion-2.6-dock.png
            safari-fusion-2.6-dock.png
            264 kB

            Issue Links

              Activity

              dobedobedoh Andrew Nicols added a comment -

              Thanks Martin,

              What theme is this on and is this with the latest changes applied?

              dobedobedoh Andrew Nicols added a comment -

              Ah, seeing this on the 'fusion' theme with the Administration block

              dobedobedoh Andrew Nicols added a comment -

              I'm seeing this in 2.4, and 2.5 too on the fusion theme with the administration block docked and the browser window smaller than the dock size. For me on an 11" display with the chrome dev tools docked to the bottom this is enough.

              dobedobedoh Andrew Nicols added a comment -

              I'm not seeing a horizontal scroll bar, but I am seeing a vertical scroll on all versions whilst using Chrome and Safari.

              I do see the Horizontal bar in Firefox.

              Just kicking windows into gear to check IE too.

              dobedobedoh Andrew Nicols added a comment -

              Unable to get my Windows VM to behave right now - I'll tinker more tomorrow.

              dobedobedoh Andrew Nicols added a comment -

              Turns out there are other themes affected. Total list includes:

              • arialist
              • fusion
              • leatherbound

              Unable to replicate in others. They get a scrollbar but in an appropriate place.
              I see another unrelated issue in Overlay where the top header sits over the block title. Attaching screenshot.

              dobedobedoh Andrew Nicols added a comment -

              I don't think that this is a recent regression - I can see it all the way back to 2.4.0. Haven't tried 2.3 so not sure about that.

              samhemelryk Sam Hemelryk added a comment -

              Thanks Andrew - looks spot on - putting this straight up for integration review.

              Integrator - I have tested this in every single core theme. If you want assign me as tester and I'll pass it happily.
              The only thing I noted was that the dock is completely unavailable in the anomaly theme, I confirmed it was entirely unrelated to this change.

              poltawski Dan Poltawski added a comment -

              The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week.

              TIA and ciao

              lazydaisy Mary Evans added a comment -

              Hi Andrew...thanks for fixing this, I'm just fixing MDL-42739 (hopefully!)

              poltawski Dan Poltawski added a comment -

              Given this is not a 2.6 regression, i'm removing MUST fix for 2.6.

              poltawski Dan Poltawski added a comment -

              And also, not integrating at this time because it requires a fair amount of testing which we don't have in ample supply at this time.

              marina Marina Glancy added a comment -

              Thanks Andrew, integrated in 2.4, 2.5, 2.6

              marina Marina Glancy added a comment -

              Andrew, I removed Clean from testing instructions - it does not support block docking yet

              skodak Petr Skoda added a comment -

              seems to work fine for me, thanks!

              lazydaisy Mary Evans added a comment -

              Glad it got fixed. But I am wondering what really caused this regression, as it was not always like that?

              marina Marina Glancy added a comment -

              Mary I tried to backtrace it and could not really find the origin of regression. Maybe it has just always been like that

              lazydaisy Mary Evans added a comment -

              I don't think it has always been like that. If it was we would have had lots of complaints in the forum.

              damyon Damyon Wiese added a comment -

              Here lies 52 bugs.
              All fixed or swept under a rug.
              If they come back one day,
              To our dismay,
              We all will feel quite un-smug.

              Thanks for the reporting/fixing/testing on this issue. It has been sent upstream.

              lazydaisy Mary Evans added a comment -

              Just noting that tge problem in Arialist, Fusion with the scroller was being caused by a float: right in the css for the commands.

               

              #dockeditempanel .dockeditempanel_hd .commands {
                  float: right;
              }

              lazydaisy Mary Evans added a comment - - edited

              Just for the record I also found that when using Firebug that the problem in Overlay exists where the first docked item title is hidden beneath the fixed topbar, which makes it a z-index problem.


                People

                • Votes:
                  0 Vote for this issue
                  Watchers:
                  8 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    11/Nov/13