Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-42711

Bootstrap base: import visual fixes from learnmoodle

    Details

    • Type: Task
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.6
    • Fix Version/s: 2.6
    • Component/s: Themes
    • Labels:
    • Testing Instructions:

      1) test mod chat in a course

      • once with course using non-bootstrapbased theme , this should have no option for 'course theme' under themes options in chat popup window.
      • once with course using a bootstrapbased theme.
      • input box should be wider - full even.

      mod chat should look much nicer, more responsive than previous old mod_chat themes (bubble & compact).
      2) test rss block:

      • create an rss block with a feed to RSS items with very long titles. the block should display nice - wrapping where necessary.
      • test that it looks ok font size and contrast wise.

      3) (see MDLSITE-2455 for more context) test : trust David Mudrak. alternatively install a GA script and reproduce it coming up in navbar as mentioned in MDLSITE-2455.

      4) test that glossary filter's pop up dialog box (yui) on clicked glossary terms specify 'OK' instead of hardcoded 'Ok'. (this is now translatable string too)

      5) test mod_choice :

      • more than 5 choice options displayed on the choosing screen won't overflow over block on the right.
      • check that the results data looks ok too.

      6) on a small screen - typically less that 768px:

      • check that (ubuntu like) course icon on course overview page stays on left top when a course with a long title wraps on smaller screens.
      • a long title should not wrap unnecessarily when there is space on the right of the title.

      7) test mod_data: on edit template or other mod_data setup type tabs, check that tinymce does wrap simply for some sanity in using it on smaller screens.

      8) test mod_forum: group icons on forum posts (blog posts too) are aligned and middled under user's picture.

      9) test mod_survey: the style on the page and radio options etc should be much more improved than the older clean theme (undefined) one.

      10) test upcoming events block: more aligned content (create some events in calendar please)

      11) test latest news block too with some news forum entires. they should also look well aligned. the actual news should be above the rest of a news item's content.

      12) test mod_feedback: the graphs bars depicting the feedback chart should be nice and sexy.

      Show
      1) test mod chat in a course once with course using non-bootstrapbased theme , this should have no option for 'course theme' under themes options in chat popup window. once with course using a bootstrapbased theme. input box should be wider - full even. mod chat should look much nicer, more responsive than previous old mod_chat themes (bubble & compact). 2) test rss block: create an rss block with a feed to RSS items with very long titles. the block should display nice - wrapping where necessary. test that it looks ok font size and contrast wise. 3) (see MDLSITE-2455 for more context) test : trust David Mudrak. alternatively install a GA script and reproduce it coming up in navbar as mentioned in MDLSITE-2455 . 4) test that glossary filter's pop up dialog box (yui) on clicked glossary terms specify 'OK' instead of hardcoded 'Ok'. (this is now translatable string too) 5) test mod_choice : more than 5 choice options displayed on the choosing screen won't overflow over block on the right. check that the results data looks ok too. 6) on a small screen - typically less that 768px: check that (ubuntu like) course icon on course overview page stays on left top when a course with a long title wraps on smaller screens. a long title should not wrap unnecessarily when there is space on the right of the title. 7) test mod_data: on edit template or other mod_data setup type tabs, check that tinymce does wrap simply for some sanity in using it on smaller screens. 8) test mod_forum: group icons on forum posts (blog posts too) are aligned and middled under user's picture. 9) test mod_survey: the style on the page and radio options etc should be much more improved than the older clean theme (undefined) one. 10) test upcoming events block: more aligned content (create some events in calendar please) 11) test latest news block too with some news forum entires. they should also look well aligned. the actual news should be above the rest of a news item's content. 12) test mod_feedback: the graphs bars depicting the feedback chart should be nice and sexy.
    • Affected Branches:
      MOODLE_26_STABLE
    • Fixed Branches:
      MOODLE_26_STABLE
    • Pull from Repository:
    • Pull Master Branch:
      MDL-42711-master

      Description

      Port all the theme/rendering/css fixes from learnmoodle repository into core Bootstrap.

        Gliffy Diagrams

          Issue Links

            Activity

            nebgor Aparup Banerjee added a comment -

            the improvements to chat were hacked in - aligning it now with our bootstrapbase theme. also allowing chat's styles to be from the course's theme style.

            lazydaisy Mary Evans added a comment -

            What do you mean by 'hacked in'? Are you saying they were only a temporary fix?

            nebgor Aparup Banerjee added a comment - - edited

            see
            https://tracker.moodle.org/browse/MDLSITE-2429?focusedCommentId=242659&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-242659

            I've now put in an option (in addition to bubble and compact), that will show 'course theme' as an option. this will use the theme's CSS for styling the chat window.
            This option will only show up for when a course is using a bootstrapbase based theme. (As the css for chat window will be in bootstrapbase)

            nebgor Aparup Banerjee added a comment - - edited

            ok, i've run through branches in our learmoodle (did my commit shopping via github).

            LMNET-2.5.2-block_rss_client-fix-words-break --> picked. thanks David Mudrak.
            LMNET-2.5.2-core_course-hack-section-titles --> skipped (MDL-40833)
            LMNET-2.5.2-core-fix-navigationlib --> picked.
            LMNET-2.5.2-core_pix-hack-moodlelogo -->picked (thx Barbara Ramiro : ......@todo
            [16:09:59] <aparup> should this go into core? https://github.com/moodlehq/learnmoodlenet/commit/579fcdc855b1ab50237fe932725367795a0b7623
            [16:23:30] <barbara@moodle.org> yes if it is not yet there

            https://github.com/moodlehq/learnmoodlenet/commits/LMNET-2.5.2-yui-fix-lang-ok --> picked.

            other hacks were not included.

            for further consideration or issue spawning (feature?):
            https://github.com/moodlehq/learnmoodlenet/commits/LMNET-2.5.2-enrol_self-hack-autoenrol

            https://github.com/moodlehq/learnmoodlenet/commits/LMNET-2.5.2-report_overviewstats-addon (was submitted to plugins DB )

            – below is todo –

            and finally https://github.com/moodlehq/learnmoodlenet/commits/LMNET-2.5.2-theme_learnmoodle-addon (picked ones would have to be brought across into theme/bootstrapbase/less/*..):

            • "Font-color changes" 9b9c8bf5e29f0d662a6024eddbbba72ea797041f – skipped
            • "Coursebox background-color changed for better contrast" 3f4a3029aca6f4c80ca4c6007c1f0b13fd3835bc – skipped
            • "MDLSITE-2397 Improve the visited URLs making up for analytics" – skipped (pls open new issue if desired)
            • "MDLSITE-2427 messages screen fixed ..." dcecb8a7f60271976401c379faeedaff7bc4f50b – @todo RTL/verify/crosspick hunk for 'calendar events block padding'
            • 'Tone down "Twitter handle" hyperlink' c3961b7e28ea435eecf9975ce3d0f2740ac88164 – @todo cross pick
            • "Info, Date and Author on the Latest News block reordered" fed09bb2a160157ade3328d5c16f5ab390f44d96 – @todo crosspick.
            • "Backport RSS block styling from the live style" 0dbd8989c8968d260434f8ec9c9c6cf80f3b81e8 – skip custom curves.
            • "GA stuff" – skipped
            • "MDLSITE-2445 Improve the forum layout on small screen devices" – @todo cross pick
            • "Reordering the Latest News block Info, date and name through CSS alone without changing the HTML" 334e905656ce03c791ae79e4cec38c067ca35a29 – skip
            • "MDLSITE-2449 padded tinymce's iframe slightly on the left. just the n…on-fullscreen view"6326766fa862acdffee1d16c88ad2186af91472a – skipped (many changes to tinymce since this commit - not merging as well as its hacky)
            • MDLSITE-2421 - skipped - LM theme specific.
            • MDLSITE-2456 - skipped LM specific fonts.
            • MDLSITE-2451 - c927823509f3ea0671560a800d4106fe053c3aa4 - @todo crosspick.
            • "added margin top to block-region for phone view" - skipped (LM specific)
            • MDLSITE-2462 fixed right oveflow of iframe in tinymce - c2c1f025a988432b72af2dcfd3f1dd8bb70e4e1b - skipping - patch uses !important - not integrating.
            • MDLSITE-2461 fixed up coursesearchbox go button. - a47655576105b58433eadff9e4a6a220595aff27 - pick (if not already fixed in master)
            • "moved smaller @media width below .." - skipped
            • "More colour contrast for hyperlinks and custom menu" - skipped
            • "Restyled Chat Compact theme merged and resolved simple conflict" - already reworked and done.
            • "Theme Variants: Orange light font, Orange regular font, Blue light font, Blue regular font" - these are colour specific to LM but perhaps a new issue should be raised here re: accessible theme variants. Barbara Ramiro?
            • "MDLSITE-nobug updated blockquote link colour to match theme colours" – skipped (LM specific)
            • MDLSITE-2473 - basically "reports need the right hand side to be clear of blocks in order to scroll" is a bug imo, the default layout could be smarter. - @todo create MDL
            • "MDLSITE-2463 made td display as block for lower widths to wrap tinymce" - fixes mod/data tinymce display in smaller widths. @todo cross pick the hunk.
            • "MDLSITE-2480 fixed up offset course name icon for small widths, where course name wraps." - 5f27c3f9d3ef511294ae5071ce2edf6ed06b8018 & 9639ac42e4389b0b5ff714f8cdf29d9593e25567 - @todo pick, not fixed in master.
            • "Backport some Survey module styling from the standard theme" - 1a340b46116a7821025e76d4870404313908d37b - @todo pick across.
            • "fixed up mod_feedback analysis bar heights from auto to 5px" - 4a85dcbf72876b91419f0006369e1cbbedfc4887 - @todo pick across.
            • "MDLSITE-2497 fixed up choice results table overflowing to right" - a7ef6ff32fdcb251801f11f018a4156103f857b9 - @todo pick hunk across (or not, see MDLSITE-2473 above)

            (feel free to comment on pickings guys - you've been tagged here :-D)

            with pickings reviewed, now proceeding to pick across to my branch.

            mudrd8mz David Mudrak added a comment -

            Grrr, was trying to help here by having a clone installed off the Apu's branch and going through my commits into theme/learnmoodle at the LMNET-2.5.2 branch. Unfortunately, I am stuck on generating the CSS files from the LESS file at the moment (recess reports an error

            $ recess --compile --compress moodle.less > ../style/moodle.css
             
            /usr/lib/node_modules/recess/lib/core.js:93
                          that.log(err.name.red + ": " + err.message + ' of ' + err.filena
             

            I need a fresh head to sort this out, will continue tomorrow.

            nebgor Aparup Banerjee added a comment -

            np David, was more confident on your commits. (Using Less to compile here)

            barbararamiro Barbara Ramiro added a comment -

            Apu, here's the chat for clean theme with minimal styling https://github.com/barbararamiro/moodle/commits/MDL-42711-master

            Will talk to you tomorrow re the theme options styling which might need to be done in html/renderer

            nebgor Aparup Banerjee added a comment -

            thanks, i've picked your changes Barb (amended commit message slightly for integration). Have also pulled in David's pull request. we should be almost done.

            nebgor Aparup Banerjee added a comment -

            i think this is close and could possibly make it in

            • am writing up tests now. (feel free to add Barb/David/LM team)
            barbararamiro Barbara Ramiro added a comment -

            Sorry Apu, i realized the link was not specific to my commit about the chat style. Anyway, here goes https://github.com/barbararamiro/moodle/commit/01d7f19235f1ae6034cc12668a1dd24a48ccbd17

            dougiamas Martin Dougiamas added a comment -

            The chat stuff looks good. MUCH better than clean does now.

            barbararamiro Barbara Ramiro added a comment -

            Apu, this is the fix for chrome and safari max-width issue https://github.com/barbararamiro/moodle/commit/14a20e07fb386bd18fe56a0aefd83d412bbea30a

            nebgor Aparup Banerjee added a comment -

            that pulled in now Barb, thanks. all go for integration.

            dougiamas Martin Dougiamas added a comment -

            I know it's odd to have so many small issues mashed into one but these were pretty well tested on Learn Moodle in September and are really necessary to make Clean theme fully viable. So my +10 for integration.

            dougiamas Martin Dougiamas added a comment -

            Also "sexy" may be subjective.

            marina Marina Glancy added a comment - - edited

            There are some things that are great and some are not. We might integrate it partially

            4. Course listings - not good. There is a separate issue for course icon MDL-39516 and it's not that easy. This fix looks bad in compact course listings. It's even worse in RTL because the icon is on the wrong side.

            6. this change has to be made in M.core.alert and not in glossary who calls it.
            edited: just had a chat with Andrew Nicols and he said he is planning the change, something like https://gist.github.com/andrewnicols/dbfe7d2b4f66921ca1ba but it will not land that soon so for now your fix is ok.

            damyon Damyon Wiese added a comment -

            Recording some minor things: RTL missing everywhere - areas that should have it are:
            block_calendar_upcoming, block_news_items, whole of chat theme, mod-forum

            Also "Course theme" is not translatable (mod/chat/gui_ajax/module.js).

            marina Marina Glancy added a comment -

            3. I like this fix very much. load_stealth_activity() was supposed to ensure that node always exists but it looks like it does not work if activity is hidden from current user. This is a bug that should be backported to all supported stables. Actually the issue already exists: MDL-40191

            nebgor Aparup Banerjee added a comment -

            fixed - translatable strings added for 'course theme' , and 'bubble' and 'compact' too while i was there.

            nebgor Aparup Banerjee added a comment - - edited

            working on RTL-ing everything.. RTL-ing done. pls test. (gtg)

            marina Marina Glancy added a comment -

            General comment: theme/bootstrapbase/less/moodle/chat.less does not have chat prefix for rules. Which make them apply to any yui dialogue. For example the look of filepicker has changed

            damyon Damyon Wiese added a comment -

            (Just pulled this into the integration list).

            nebgor Aparup Banerjee added a comment -

            good spotting Marina,thanks!
            i've edited via github and added two .path-mod-chat's. will compile css later.

            ps:i wonder why we didn't pick the filepicker changes (or elsewhere!) up in LM, there wasn't the scope limitation there.

            nebgor Aparup Banerjee added a comment -

            ok - changes pushed - also made the input wider on the chat window finally. (thx Barb!)

            damyon Damyon Wiese added a comment -

            Thanks Aparup, David, Barbara (and anyone I missed).

            I tested this in integration and it all looks good to me. I'll pass the testing for this.

            damyon Damyon Wiese added a comment -

            Passing this test. I'll create a new issue to backport this:

            commit 1d93c9ae07da8ee08af42c698a705fd7076ccb4e
            Author: David Mudrák <david@moodle.com>
            Date: Wed Aug 21 15:13:08 2013 +0200

            MDL-42711 import learnmoodle fixes: Fix the broken links in RSS feed block

            nebgor Aparup Banerjee added a comment -

            Thanks Damyon

            i've also tested using 'theme_clean | customcss' setting, e.g.:

            .yui-skin-sam .yui-layout.path-mod-chat-gui_ajax #chat-messages .chat-message.course-theme,
            .yui-skin-sam .yui-layout.path-mod-chat-gui_ajax #chat-messages .mdl-chat-my-entry .chat-message.course-theme {
             background-color: rgba(0,55,128,0.2);
            }
            .yui-skin-sam .yui-layout.path-mod-chat-gui_ajax #chat-messages .mdl-chat-my-entry .chat-message.course-theme {
            border: 1px red solid;
            }

            i've updated http://docs.moodle.org/dev/Themes_overview#What.27s_new_in_2.6

            stronk7 Eloy Lafuente (stronk7) added a comment -

            It's Friday, I'm tired so I won't be very imaginative today.

            No matter of that, yes, you did it! Thanks for your collaboration!

            Closing this as fixed!

            schach Heiko Schach added a comment - - edited

            We noticed that setting mod_feedback analysis bar heights to 5px in "Analysis" tab (mod/feedback/analysis.php) breaks things in the "Show responses" tab (mod/feedback/show_entries.php). User pictures now appear to be squeezed to 5px height.

            This is caused by by the CSS-definition in theme/bootstrapbase/less/moodle/modules.less:

            .path-mod-feedback .generalbox div table tbody img {
                height: 5px; // we should remove the bar height specification in core
            }
            

            A more exact definition would help avoid this kind of misinterpretations.
            Something like this would work better:

            #page-mod-feedback-analysis img.feedback_bar_image {
                height: 5px; // we should remove the bar height specification in core
            }
            

            The following lines can probably be removed from mod/feedback/styles.css if they are not required by other themes.

            div img.feedback_bar_image {
                height: 10px;
            }
            

            marina Marina Glancy added a comment -

            Hi Heiko, thanks for your comment. Would you mind to create a separate issue about it because this one is already integrated and closed? Thanks again

            schach Heiko Schach added a comment -

            Ok, thanks for the info.
            I have created a separate issue MDL-46063.


              People

              • Votes:
                2 Vote for this issue
                Watchers:
                10 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  18/Nov/13