Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-42728

Import fixed English strings (en_fix) into the main English pack

    Details

    • Type: Task
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.4.7, 2.5.3
    • Fix Version/s: 2.4.7, 2.5.3
    • Component/s: Language
    • Labels:

      Description

      As a part of regular release process, en_fix pack from AMOS should be merged into the core English language

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              mudrd8mz David Mudrák added a comment -

              Post-clone cleanup.

              mudrd8mz David Mudrák added a comment -

              Submitting for integration. Thanks Helen Foster for your work on this.

              poltawski Dan Poltawski added a comment -

              As David Mo mentioned the other day, we need to do a full behat run on these to make sure its not going to cause all kinds of failures.

              I will try that now.

              poltawski Dan Poltawski added a comment -

              Looks good on master:
              281 scenarios (281 passed)
              6058 steps (6058 passed)
              203m27.606s

              poltawski Dan Poltawski added a comment -

              The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week.

              TIA and ciao

              stronk7 Eloy Lafuente (stronk7) added a comment -

              FYI, it seems that, in master, you are re-introducing a missing string (lang/en/moodle.php):

              <<<<<<< HEAD
              =======
              $string['resortselectedcategoriesby'] = 'Re-sort subcategories of selected categories';
              >>>>>>> FETCH_HEAD

              poltawski Dan Poltawski added a comment -

              I've integrated this - thanks.

              I removed that added string. I will run behat now again.

              mudrd8mz David Mudrák added a comment -

              Thanks guys. Correct - when those en_fix branches were created, the string was still in moodle.git. Thanks for spotting it.

              dmonllao David Monllaó added a comment -

              Waiting for the CI server to finish, I see 2 failures, once the job is finished I will check if they are caused by those language strings changes.

              dmonllao David Monllaó added a comment -

              sorry Dan, I didn't see your comment above, passing it.

              damyon Damyon Wiese added a comment -

              Here lies 52 bugs.
              All fixed or swept under a rug.
              If they come back one day,
              To our dismay,
              We all will feel quite un-smug.

              Thanks for the reporting/fixing/testing on this issue. It has been sent upstream.


                People

                • Votes:
                  1 Vote for this issue
                  Watchers:
                  2 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    11/Nov/13