Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-42885

Updating existing users via bulk upload causes debugging messages

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.5.3, 2.6, 2.7
    • Fix Version/s: 2.5.4, 2.6.1
    • Component/s: Administration
    • Labels:
    • Testing Instructions:
      Hide
      1. Visit <yoursite>/admin/tool/uploaduser/index.php and upload the users in the attached file.
      2. Ensure they upload successfully.
      3. Edit the file slightly by changing the user's emails.
      4. Visit <yoursite>/admin/tool/uploaduser/index.php and upload this file again (but do not finalise the upload).
      5. On the next page check "Update existing users only" and set "Existing user details" with "Override with file" and click "Upload users"
      6. Check that the next page it states that the emails were updated and there are no debugging messages.
      Show
      Visit <yoursite>/admin/tool/uploaduser/index.php and upload the users in the attached file. Ensure they upload successfully. Edit the file slightly by changing the user's emails. Visit <yoursite>/admin/tool/uploaduser/index.php and upload this file again (but do not finalise the upload). On the next page check "Update existing users only" and set "Existing user details" with "Override with file" and click "Upload users" Check that the next page it states that the emails were updated and there are no debugging messages.
    • Affected Branches:
      MOODLE_25_STABLE, MOODLE_26_STABLE, MOODLE_27_STABLE
    • Fixed Branches:
      MOODLE_25_STABLE, MOODLE_26_STABLE
    • Pull Master Branch:
      MDL-42885_master
    • Story Points:
      8
    • Sprint:
      BACKEND Sprint 7

      Description

      In master.

      Could not find htmleditor on the user objects
       
          line 554 of /admin/tool/uploaduser/index.php: call to debugging()
       
      Could not find oldusername on the user objects
       
          line 554 of /admin/tool/uploaduser/index.php: call to debugging()
       
      Could not find deleted on the user objects
       
          line 554 of /admin/tool/uploaduser/index.php: call to debugging()
       
      Could not find firstnamephonetic on the user objects
       
          line 554 of /admin/tool/uploaduser/index.php: call to debugging()
       
      Could not find lastnamephonetic on the user objects
       
          line 554 of /admin/tool/uploaduser/index.php: call to debugging()
       
      Could not find middlename on the user objects
       
          line 554 of /admin/tool/uploaduser/index.php: call to debugging()
       
      Could not find alternatename on the user objects
       
          line 554 of /admin/tool/uploaduser/index.php: call to debugging()
      

      In 2.5

      Could not find oldusername on the user objects
       
          line 551 of /admin/tool/uploaduser/index.php: call to debugging()
       
      Could not find deleted on the user objects
       
          line 551 of /admin/tool/uploaduser/index.php: call to debugging()
      

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  13/Jan/14