Moodle
  1. Moodle
  2. MDL-42907

Internet Explorer 11 and TinyMCE not working

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 2.5, 2.5.1, 2.5.2, 2.5.3
    • Fix Version/s: None
    • Component/s: Resource, Usability
    • Labels:
      None
    • Affected Branches:
      MOODLE_25_STABLE

      Description

      Moodle uses the TinyMCE 3.x editor which doesn't seem to work with IE11. This problem affects many open source software products and I don't know if it's up to Moodle to fix it.

      It probably has to do with the user agent check that in IE11 no longer returns anything with 'MSIE' in.

      http://blogs.msdn.com/b/ieinternals/archive/2013/09/21/internet-explorer-11-user-agent-string-ua-string-sniffing-compatibility-with-gecko-webkit.aspx

      As a result all users of IE11 see HTML code when they are editing pages, forumposts, etc. (basically everywhere where normally a TinyMCE editor would appear)

        Gliffy Diagrams

        1. IE11 in Win 7.jpg
          175 kB
        2. Image1.png
          33 kB
        3. moodle252_editor_not_displayed.png
          57 kB
        4. moodle252_filepicke_upload_1.png
          47 kB
        5. moodle252_filepicke_upload_2.png
          46 kB

          Issue Links

            Activity

            Michael de Raadt added a comment -

            Hi, Richard.

            I've just checked and TinyMCE seems to be working for me in IE11. What version of Moodle are you using?

            Richard van Iwaarden added a comment -

            Right now we are at Moodle 2.5.2+ (Build: 20130913)

            Where did you check this Michael? Because I have many users reporting it and I saw some other users talking about it ont he Moodle forums before it crashed, see for example Google cache of the Moodle forums http://goo.gl/V4wzFV

            This problem can be viewed best if you add a webpage to a course, insert a picture in the page en try to edit it. I will try to post a screenshot in this tracker if I know how.

            Richard van Iwaarden added a comment -

            I added a screenshot.

            Ralf Hilgenstock added a comment -

            We can confirm this problem if compatibility mode is not used for the site.

            It seams that microsoft knows about problems with IE 11 and lost of applications. In latest updates for Win7 IE11 update is disabled.

            Additionally we found that file upload doresn't work and creates a JSON error message.

            Michael de Raadt added a comment -

            Thanks for continuing to work on this, guys.

            I'm testing on 2.5.3 and the latest Master (2.6). I'm using Windows 8.1 and I assume I have the latest updates to IE11.

            I tried again to replicate the problem, enabling and disabling compatability mode. I also tried qa.moodle.net. I was consistently able to use the editor normally and upload files.

            Is there a way to force IE11 to upgrade?

            Ralf Hilgenstock added a comment -

            Hello Michael,
            we can confirm now that it works with Win 8 and IE11, but not in Win7 and IE11.
            Ralf

            Michael de Raadt added a comment -

            Hi, Ralf.

            I just tried IE11 in Win 7 and the editor seemed to work in 2.5.3 and master. The version of the browser I'm using is 11.0.9600.16428.

            Michael de Raadt added a comment -

            Also, could you try this with the standard theme and see if that makes a difference?

            Gerald Hartwig added a comment - - edited

            Hi, Michael,

            now we've checked some moodle-version. Here are the results:

            • Moodle 2.5.1+ (Build: 20130830)
            • Standard-Theme (also by using other themes)
            • IE 11.0.9600.16428
              = editor is not displayed
            • Moodle 2.5.2 (Build: 20130909)
            • Standard-Theme (also by using other themes)
            • IE 11.0.9600.16428
              = editor is not displayed (add a screenshot)
            • Moodle 2.5.3 (Build: 20131111)
            • IE 11.0.9600.16428
              = works fine
            • Moodle 2.6 (Build: 20131118)
            • IE 11.0.9600.16428
              = works fine

            Moodle 2.5.1 and 2.5.2 by using the compatability mode of IE11:

            • editor is displayed
            • but uploading a file by using file picker is not working -> JSON error (I add two screenshots), upload does not work
            Michael de Raadt added a comment -

            OK. Even though it's not working in 2.5.1 or 2.5.2, it's good that it is working on the latest versions.

            Richard and Ralf: can you confirm that an upgrade fixes the problem for you?

            Richard van Iwaarden added a comment -

            I will let you know the results when we upgrade. I don't know when we are going to do that yet, but I think we will go straight to 2.6.

            Ralf Hilgenstock added a comment -

            Gerald is a colleague here at our office. I can confirm and from my perspective we can close the ticket. Thanks.

            Michael de Raadt added a comment -

            I tend to agree, Ralf.

            But before we close this issue, I would like to hear from Richard as he was the original reporter.

            Richard van Iwaarden added a comment -

            I think we can close it. This week we will upgrade to 2.6, I was able to test this in 2.6 and could not reproduce the problem.

            Whatever the problem was... it seems solved in Moodle 2.5.3 and up.

            Michael de Raadt added a comment -

            Thanks for reporting back, Richard.

            I'm closing this issue.

            Nadav Kavalerchik added a comment -

            I still have some Moodle 2.4.x servers with this issue, Is there any thing I can do?

            Nadav Kavalerchik added a comment -

            Thanks Matteo! (just what I needed)

            Andrew Downes added a comment -

            Is there any solution for people on Moodle 2.4 or below yet (aside from doing a major update).

            If not, please can this issue be reopened? I'd really appreciate any help on this.

            Andrew

            Andrew Downes added a comment -

            Apologies, didn't see Matteo's comment. Please ignore my last comment! Thanks Matteo!

            Barry Richards added a comment -

            I followed Matteo's link to Github, however I can't apply the fix to the 2.2 installations we have as the directory/file 'tests/moodlelib_test.php' doesn't exist in the installation. Unfortunately, we are unlikely to be able to upgrade to 2.6 in the near future. Does anybody have a fix for this issue for 2.2 please?

            Matteo Scaramuccia added a comment -

            Hi Barry,
            tests are "just" for Dev&QA purposes so you should merge only 8606...8608 lines into the lib/moodlelib.php of your 2.2.

            HTH,
            Matteo

            Barry Richards added a comment -

            Ahhhhh! (followed by the sound of a penny dropping)

            Thank you Matteo for pointing me in the right direction. I'm not that familiar with the development of Moodle – I'm usually just required to hack some files locally to get something working.

            Fix applied, TinyMCE working again.

            Thanks,
            Barry

            Cameron Banfield added a comment -

            Still not fully working. It's not possible to create hyperlinks

            Michael de Raadt added a comment -

            Hi, Cameron.

            I suggest you create a new issue.


              People

              • Votes:
                3 Vote for this issue
                Watchers:
                15 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: