Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-42929

Bump backup internal version and release information

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.6, 2.7
    • Fix Version/s: 2.6.1
    • Component/s: Backup
    • Labels:
      None
    • Testing Instructions:

      Manual:
      1) Perform 1 backup of any course.

      2) Download the resulting .mbz file.

      3) Uncompress it (may be in .zip or .tgz format).

      5) Look to the "moodle_backup.xml" file"

      6) TEST: Verify these contents are in the <information> tag:

      <backup_version>YYYYMMDD00</backup_version>
      <backup_release>X.Y</backup_release>
      

      (and they match the values in the main version.php file)

      Automatic:
      1) The version checker job in the CI servers pass perfectly both for the new stable branch and for master.

      Show
      Manual: 1) Perform 1 backup of any course. 2) Download the resulting .mbz file. 3) Uncompress it (may be in .zip or .tgz format). 5) Look to the "moodle_backup.xml" file" 6) TEST: Verify these contents are in the <information> tag: <backup_version>YYYYMMDD00</backup_version> <backup_release>X.Y</backup_release> (and they match the values in the main version.php file) Automatic: 1) The version checker job in the CI servers pass perfectly both for the new stable branch and for master.
    • Affected Branches:
      MOODLE_26_STABLE, MOODLE_27_STABLE
    • Fixed Branches:
      MOODLE_26_STABLE
    • Pull from Repository:
    • Pull Master Branch:

      Description

      We use to update the internal backup version and release on majors. While it's not used along the process, that information is included on each backup and has helped in the past to detect inconsistencies caused by codebase partially updated and other problems.

      Since Moodle 2.4 we are checking version & release with the CI versions checker so this is a task that we should perform always immediately after a major release (hence has been included in http://docs.moodle.org/dev/Release_process_(Combined)#Release).

      Summary:

      1) Both in the new stable branch and in master (file backup/backup.class.php):

      • Update VERSION to match $version (8 digits).
      • Update RELEASE to match $release (X.Y format).

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              stronk7 Eloy Lafuente (stronk7) added a comment -

              Sending straight to integration. It does not requires P2P.

              damyon Damyon Wiese added a comment -

              Thanks Eloy,

              Integrated to master and 26.

              Looks correct to me. Tested the first part in integration, will wait for CI to pass the second one.

              damyon Damyon Wiese added a comment -

              (CI passed the 2nd tests).

              stronk7 Eloy Lafuente (stronk7) added a comment -

              ...
              But still, I thank you, for you made me stronger…

              Stronger as the beast that roar in the wild
              Stronger as the storm across the ocean
              Stronger as the diamond that won’t break
              Stronger enough to take all heart aches….

              I thank you my friend, for you made me stronger…

              ---- Juneah Landicho

              Closing as fixed. Ciao


                People

                • Votes:
                  0 Vote for this issue
                  Watchers:
                  1 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    13/Jan/14