Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-42992

SCORM window cannot be resized in IE 9

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.6
    • Fix Version/s: 2.6.1
    • Component/s: SCORM

      Description

      This issue is caused by MDL-32506.

      Even though the feature "Allow window to be resized" was determined to be an obsolete setting in MDL-32506, the removal of the feature now causes problems in IE9.
      SCORM packages which were uploaded before the upgrade of 2.6 can still be resized.

      New SCORM packages, uploaded after 2.6, are affected by the removal of this feature. The popup cannot be resized in IE9, which is causing tremendous problems for our users which are mainly on IE9. No issues in IE 10 though.

      Please add the feature back in. IE 9 cannot be compared with IE 5.5. IE 9 still has a market share of about 9.5 (http://www.netmarketshare.com/browser-market-share.aspx?qprid=2&qpcustomd=0)

        Gliffy Diagrams

          Issue Links

            Activity

            danmarsden Dan Marsden added a comment -

            Thanks for the report - we won't add the tickbox back but we should definitely make sure that IE 9 can still resize windows.

            icefresh Michael E added a comment -

            That's fine. I can test it once it passed the peer review.

            samhemelryk Sam Hemelryk added a comment -

            Looks spot on thanks Dan - pushing to integration now.

            poltawski Dan Poltawski added a comment -

            Integrated to master and 26

            poltawski Dan Poltawski added a comment -

            thanks

            icefresh Michael E added a comment -

            Thanks. I tested it and here are the results:

            • Now, IE9 does not open a new window anymore - it opens a new tab. (This behavior was not present prior to the fix)
            • Resizing the window (with the tab in it) works though

            Unfortunately I cannot pass or fail the test – it looks like being a QA tester does not allow me to test such fixes.

            danmarsden Dan Marsden added a comment -

            Michael - are you sure that your browser configuration hasn't changed which is now causing the new tab to occur? - to test this change properly you need to use the integration git repository - check out the repository before the fix and clear caches, then reproduce the original issue.
            Then upgrade the site using the integration git repository after the patch, clear caches and check to see if the issue is fixed.

            The key here is to first reproduce the original issue and using the integration repository before trying to see if the fix has worked - if you are unable to do this then someone else from the team will do the work. Thanks.

            icefresh Michael E added a comment -

            Dan - the configuration did not change. Unfortunately, I cannot access the integration git repo from here. We are behind a firewall. I was not able to connect to it via https either. So I just implemented the code changes manually.
            It is probably the best idea, if somebody else would test it, directly from the integration repo.
            I will try to test it at home, but in the meantime I do not want to hold up this fix - so I removed myself as tester.

            abgreeve Adrian Greeve added a comment -

            Tested on the master and 2.6 integration branches.
            Tested pre-patch to observe the problem.
            Works as described.
            Test passed.

            poltawski Dan Poltawski added a comment -

            Congratulations, this change has now made its way upstream. Thanks for your contribution!

            “ Always code as if the guy who ends up maintaining your code will be a violent psychopath who knows where you live. ” - Rick Osborne


              People

              • Votes:
                2 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  13/Jan/14