Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-43019

SCORM does not appear when launched on IE11 before the browser window is resized

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.5.3
    • Fix Version/s: 2.4.8, 2.5.4
    • Component/s: SCORM
    • Labels:
      None
    • Testing Instructions:

      This is a change to 2.4Stable and 2.5Stable branches only - 2.6 already has this patch.
      Please test in Multiple browsers including IE 8 and IE 11
      Add the attached SCORM package to your site and enter it as a student.
      Make sure the SCORM content appears.
      make sure no new JavaScript errors related to the player occur.

      Show
      This is a change to 2.4Stable and 2.5Stable branches only - 2.6 already has this patch. Please test in Multiple browsers including IE 8 and IE 11 Add the attached SCORM package to your site and enter it as a student. Make sure the SCORM content appears. make sure no new JavaScript errors related to the player occur.
    • Affected Branches:
      MOODLE_25_STABLE
    • Fixed Branches:
      MOODLE_24_STABLE, MOODLE_25_STABLE

      Description

      There is a SCORM package created on:

      Articulate Storyline
      version: 1.3.1305.2012
      xmlversion: 1.2

      On Internet Explorer version 11.0.9600.16438:

      When the link to the package on a course page it is added to is clicked, the container pane for the content appears, but the content does not show inside it. The content does appear when the window is resized. Any resize works, including making the window smaller. This happens with package settings set to display content in both 'current window' AND on a 'new window'.

      The package does appear normally on IE11 when launched directly from the desktop.

        Gliffy Diagrams

          Issue Links

            Activity

            mert Mert Kecik added a comment -

            This issue is replicated on a v2.4.3 site as well. Please let me know if the issue description needs to be further clarified.
            Thank you

            matteo Matteo Scaramuccia added a comment -

            Hi Mert,
            it would be nice if you could provide a demo version of your package, affected by this issue too: this will help the investigations on the interactions between Moodle and your Package, under IE11.

            TIA,
            Matteo

            danmarsden Dan Marsden added a comment -

            also - please update your version of Storyline - there have been 2 updates since your version - the current version is 1.3.1311.1422, after updating storyline please re-export your SCORM package and test it again.

            mgancarzdsi Mathew Gancarz added a comment -

            I'm seeing a similar issue, happening both on our new 2.5.3 test site and on our old 2.2.10 site. When clicking on a SCORM module, it starts loading but shows a blank screen. Browser icon is still spinning though indicating it's loading something. After about ~2 minutes of waiting the module finishes loading. In my tests, resizing browser didn't make any difference.

            Using Windows 7 and IE 11.0.9600.16428 (issue does not occur on Windows 8) and I noticed it only happens when using the new default "Edge" document mode of IE11. When I switch Document to 10 in developer console, the SCORM module loads fine.

            SCORM modules tested were produced with Lectora Inspire 11.3 and 10.6, both acted the same.

            mgancarzdsi Mathew Gancarz added a comment -

            Doing some additional testing with Fiddler 2 running to examine the web traffic..

            With Fiddler proxying the traffic, it takes about 30 seconds to load on "Edge" mode, compared to about 2 seconds on "10" Document mode.
            Fiddler shows /mod/scorm/loadSCO.php?a=etc.. starts loading, sending only the headers and 0 content length. It then completes loading 30 seconds later and returns the LoadSCO content.

            Same issue occurs on a vendor's site that we are using to test a new 2.5.3 theme, the "Features Demo" course that has the "eXe SCORM package" shows similar behaviour, taking ~30 seconds to load.

            danmarsden Dan Marsden added a comment -

            Matthew - the issue you are describing is quite different to the reporter here - please use a different issue/discussion for your problem - thanks!

            mgancarzdsi Mathew Gancarz added a comment -

            Sorry, was not sure if it is preferable to lump similar things together or not. Created separate issue https://tracker.moodle.org/browse/MDL-43059

            danmarsden Dan Marsden added a comment -

            thanks.

            mert Mert Kecik added a comment -

            I have attached a package file for testing as Matteo suggested.
            Thanks

            mgancarzdsi Mathew Gancarz added a comment -

            Hi Dan and Mert, it turns out IE11 behaves differently on my home machine than on my work machine, even though they are both Windows 7 and appear to be the same IE 11 version. On my home machine I get same behaviour as you get Mert, though we use Lectora. With SCORM packages in our older courses, which were created in Lectora X.6 or earlier, we get the same behaviour. But anything we've published in Lectora 11 loads properly.

            I ran Fiddler, and all of the data is being loaded properly, /mod/scorm/loadSCO.php completes quickly and then it starts loading /pluginfile.php/###/mod_scorm/content/.... I also see it load /mod/scorm/datamodel.php and
            It just doesn't seem to render the SCORM package in the window until the IE11 window is resized.

            mgancarzdsi Mathew Gancarz added a comment -

            One other note, the package not being displayed until the window is resized also happens on Windows 8 IE 11, in both the desktop and Metro version. Unfortunately in the Metro version since it's full-screen by definition, there is no easy way to resize the window other than to do the Metro "Snap"

            mgancarzdsi Mathew Gancarz added a comment -

            As a workaround on our site, we've added <meta http-equiv="x-ua-compatible" content="IE=8"> to the theme right after the <head>. This prevents the issue from happening on IE11. Tested with IE=edge, 10 and 9. Only setting it to IE=8 prevented the issue from occuring.

            danmarsden Dan Marsden added a comment -

            Thanks to some help from Matthew I've been taking a look at this today - I can reproduce the issue in 2.5 but the problem doesn't occur in Moodle 2.6
            I'd like to fix it in our stable releases but if you have the option to upgrade to 2.6 it will help.

            danmarsden Dan Marsden added a comment -

            a backport of MDL-40702 seems to fix this - the code that creates those objects was always pretty nasty and using an iframe instead of object fixes a few other problems from occurring too. pushing this up for peer review.

            danmarsden Dan Marsden added a comment -

            NOTE TO INTEGRATOR/PEER-REVIEWER:
            This is a stable only change - it exists in 2.6 already (see linked bug)

            mgancarzdsi Mathew Gancarz added a comment -

            Thank you Dan, tested the patch in 2.5.3 and confirmed that it resolves my issues with our Lectora packages and IE11.

            poltawski Dan Poltawski added a comment -

            +1 makes sense to me especially if already proven on 26, thanks Dan.

            danmarsden Dan Marsden added a comment -

            Thanks Matthew/Dan

            samhemelryk Sam Hemelryk added a comment -

            Thanks Dan - this has been integrated now.

            fred Frédéric Massart added a comment -

            Passed. Tested on 2.4 and 2.5 with IE8, IE11, Safari and FF.

            samhemelryk Sam Hemelryk added a comment -

            Thanks for the code, its now upstream!

            Heres a fun trick to try in the spirit of Friday the 13th.
            I hear if you stand in front a mirror, alone, in the dark, and say "Oracle" three times Petr Skoka will appear in the mirror and you'll see him deleting the Oracle driver from Moodle.

            susanhcheng Susan Cheng added a comment -

            Hi Mathew, So glad found this post here, since we got the same issue on IE11 too (we use Moodle 2.4 currently). The only different thing is our SCORM is converted from Flash, could you please tell me which file that you modified when you say add "<meta http-equiv="x-ua-compatible" content="IE=8">" to the theme after <head>? Is the Moodle file or SCORM file?

            Thanks a lot.

            susanhcheng Susan Cheng added a comment -

            Hi Mathew, I have figured it out, it's working now.

            Cheers!

            mgancarzdsi Mathew Gancarz added a comment - - edited

            Great to hear Susan! I just want to add the meta tag fix is a band-aid workaround as all it does is ask IE to render in IE8 mode, which slightly degrades the visual appearance of the entire site. Since you are already on Moodle 2.4, I'd recommend just updating to 2.4.8 or the latest, since that actually implements the fix in the SCORM core rendering code itself.


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                8 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  13/Jan/14