Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-43050

Fix composer version when master becomes MOODLE_XY_STABLE

    XMLWordPrintable

Details

    • MOODLE_26_STABLE
    • MOODLE_26_STABLE
    • MDL-43050_master
    • Hide

      Note that these testing instructions are pretty artificial, in fact checking that composer.json has a 1.26.2 should be enough, but:

      1. cd /your/moodle/dirroot
      2. rm -rf vendor/
      3. rm composer.lock
      4. php composer.phar update --dev
      5. Open composer.lock, you SHOULD see that the moodlehq/behat-extension version is moodle 1.26.2
      Show
      Note that these testing instructions are pretty artificial, in fact checking that composer.json has a 1.26.2 should be enough, but: cd /your/moodle/dirroot rm -rf vendor/ rm composer.lock php composer.phar update --dev Open composer.lock, you SHOULD see that the moodlehq/behat-extension version is moodle 1.26.2

    Description

      When the current master branch becomes a stable one we need to:

      • Fix the composer.json version of moodlehq/behat-extension:
        • In master it is specified as a wildcard, so 1.NN.* will pick the last version of moodlehq/behat-extension
        • If we want to introduce and backport changes in moodlehq/behat-extension we should maintain backwards compatibility, otherwise using the wildcard the last moodlehq/behat-extension version will be pulled by composer and may be calling moodle codebase functions that are not available because (for example) 2.NN.0 is being used.
      • Fix the versions of the dependencies:
        • In master they are specified as wildcards, so N.XY.* will pick the last version of whatever dependency it is.
        • If there are changes in upstream projects the tests may not be ready to use them or can just break; in master we have room to fix it, but not in stable where they should always be passing.

      We did both things when we released Moodle 2.5, but few days ago when we release Moodle 2.6 we only did the 2nd one (my fault, I forgot the reason why we needed to hardcode it also in Moodle's composer.json) so this issue is only affecting 2.6

      Attachments

        Issue Links

          Activity

            People

              dmonllao David Monllaó
              dmonllao David Monllaó
              Frédéric Massart Frédéric Massart
              Dan Poltawski Dan Poltawski
              Dan Poltawski Dan Poltawski
              Andrew Lyons, Huong Nguyen, Jun Pataleta, Michael Hawkins, Shamim Rezaie, Simey Lameze
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:
                13/Jan/14