Moodle
  1. Moodle
  2. MDL-43062

Content of label is left-aligned, regardless of alignment chosen

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.6
    • Fix Version/s: 2.6.1
    • Component/s: Course, Resource
    • Labels:
    • Testing Instructions:

      Go to course listing in Standard and Clean
      Create a label that contains three lines:

      • a right aligned text
      • a left aligned text
      • a center aligned
        Create a label on one line

      Check that you can:

      • intend the labels and a none label activity
      • that the label containing left-center-right algniment are always correctly aligned.

      Check these two points for editing on and off.

      Show
      Go to course listing in Standard and Clean Create a label that contains three lines: a right aligned text a left aligned text a center aligned Create a label on one line Check that you can: intend the labels and a none label activity that the label containing left-center-right algniment are always correctly aligned. Check these two points for editing on and off.
    • Affected Branches:
      MOODLE_26_STABLE
    • Fixed Branches:
      MOODLE_26_STABLE
    • Pull 2.6 Branch:
    • Pull Master Branch:
      MDL-43062-master-nomerge
    • Story Points (Obsolete):
      8
    • Sprint:
      FRONTEND Sprint 7

      Description

      When you center or right-align text or images in a label, it appears correctly in the editor, but is always left-aligned when displayed on the course page. Prior to upgrading to 2.6, in 2.4, I used to be able to have content appearing in the center or right of the course page.

        Gliffy Diagrams

          Activity

          Michael Woods added a comment -

          This screenshot is showing the right-aligned text in the editor, in Clean theme.

          Michael Woods added a comment -

          This screenshot shows the text as left-aligned, even though I specified it as right-aligned in the editor.

          Michael de Raadt added a comment -

          Thanks for reporting that, Michael.

          It looks like the container is not stretching across the course page as it did in previous versions, so area that the label is centred in is only as wide as the content.

          Where more content is added it does stretch wider. I will add some screenshots to demonstrate this.

          Michael de Raadt added a comment -

          I checked this and the same problem appears with editing off.

          Michael Woods added a comment -

          Ah, I see! Feel free to update my bug title and/or description to better reflect what the issue is.

          Jérôme Mouneyrac added a comment -

          Sent for peer-review.

          Rajesh Taneja added a comment -

          Sorry Jerome,

          This get off my radar.

          Please consider following before pushing it for integration:

          1. Typo (lanel) https://github.com/mouneyrac/moodle/compare/f7434db...MDL-43062-master-2#diff-f4e131c85cb9fd36356f69248e439527R48
          2. Missing space between float and padding. https://github.com/mouneyrac/moodle/compare/f7434db...MDL-43062-master-2#diff-851e8bf0bb37e144c4d197efae84adeaR785
          3. .section .activity .mod-indent-outer is already defined, do we really need .section .lanel .mod-indent-outer ?
          4. Finally not sure if this patch is solving the problem as the problem is happening because of Display set to table (.section .activity .mod-indent-outer) and table-cell (.course-content .section .activity .contentwithoutlink)

          Also, should this be fixed for bootstrap theme ?

          Jérôme Mouneyrac added a comment - - edited

          Thanks Raj for your good peer-reviews. All fixed and added to bootstrap. Sending to integration.

          Sam Hemelryk added a comment -

          Thanks Jerome - this has been integrated now.

          David Monllaó added a comment -

          It passes

          Damyon Wiese added a comment -

          Twas the week before Christmas,
          And all though HQ
          Devs were scrambling to finish peer review.
          They sent all their issues,
          and rushed out the door -
          "To the beach!" someone heard them roar!

          This issue has been released upstream. Thanks!

          Matt Fedorko added a comment -

          I know that this is closed, but I believe this also fixes a bug I reported as MDL-44068. Could some verify this, and close MDL-44068 as fixed, if so? I don't have the ability to verify it myself.

          Sam Hemelryk added a comment -

          Thanks for pinging about that Matt. I tested it this morning and indeed it has been fixed as well. I've now closed MDL-44068.

          Fernando Oliveira added a comment -

          Looks like this problem persists in Moodle 2.7.

          Marina Glancy added a comment -

          Fernando, I've just checked, the labels are aligned correctly in 2.7. If you believe it is an issue, please create a new bug report with screenshots are reproduction instructions.

          Fernando Oliveira added a comment -

          Sorry, I was responding to Micheal's point, where he says:

          "It looks like the container is not stretching across the course page as it did in previous versions, so area that the label is centred in is only as wide as the content."

          So, if I create a label with a table that is 100% wide, the actual width of the table is only as wide as the content within the table. The table does not stretch.

          That said, this is probably not the right page for this issue. I will look around.

          Thanks.

          Marina Glancy added a comment -

          yes I know what you mean but it still looks balanced when editing mode is off (and this is how students see it). So I'm not sure that it's an issue anyway


            People

            • Votes:
              1 Vote for this issue
              Watchers:
              10 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Agile