Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-43079

notice in statistics graph causes graph not to load when all students have same zero grade for all questions

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.4.7, 2.5.3, 2.6, 2.7
    • Fix Version/s: 2.4.8, 2.5.4, 2.6.1
    • Component/s: Quiz
    • Labels:
    • Testing Instructions:

      Make sure your Moodle is displaying developer debug messages.

      Create a quiz in a course with one or more questions.

      Log in as two different students and attempt the quiz, make sure to get all questions wrong.

      Go to Results -> Statistics in the Quiz Admin menu.

      Before applying patch you will not see a graph just a broken image icon. And there will be notices in your apache log and you will also see the same notices if you right click on the broken image icon and open the image url.

      After patch the graph will show up.

      Show
      Make sure your Moodle is displaying developer debug messages. Create a quiz in a course with one or more questions. Log in as two different students and attempt the quiz, make sure to get all questions wrong. Go to Results -> Statistics in the Quiz Admin menu. Before applying patch you will not see a graph just a broken image icon. And there will be notices in your apache log and you will also see the same notices if you right click on the broken image icon and open the image url. After patch the graph will show up.
    • Affected Branches:
      MOODLE_24_STABLE, MOODLE_25_STABLE, MOODLE_26_STABLE, MOODLE_27_STABLE
    • Fixed Branches:
      MOODLE_24_STABLE, MOODLE_25_STABLE, MOODLE_26_STABLE
    • Pull Master Branch:
      MDL-43079-master-v2

      Description

      Only causes graph not to display when in debug mode, when it will screw up sending headers.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              salvetore Michael de Raadt added a comment -

              Hi, Jamie.

              I wasn't able to replicate this. I added some attempts from students who got zero marks. The graph didn't appear, but I didn't see any notice.

              fred Frédéric Massart added a comment -

              Thanks for filing that bug Jamie. Michael, I initially reproduced this in MDL-42957, the notices are found in the Apache logs.

              jamiesensei Jamie Pratt added a comment -

              That's correct Fred. The notices are thrown by the script that produces the graph image so the graph image does not display, if you right click on where it did not display and open the image link then you can see the notices, as well as in the apache log.

              salvetore Michael de Raadt added a comment -

              Right. Thanks for clarifying that. Fast work, gentlemen,

              fred Frédéric Massart added a comment -

              (I removed the regression tag as it does not seem to be specific to 2.6)

              rwijaya Rossiani Wijaya added a comment -

              Hi Jamie,

              The fix seems to fix the error message. However I'm not 100% sure if it is the proper way to fix this.

              I'm adding Tim Hunt as watcher and to add his opinion on this issue.

              Tim,

              Please feel free to assign yourself as peer-reviewer for this issue.

              timhunt Tim Hunt added a comment -

              That looks like a good way to fix this. However, I think the commit comment could be clearer. The bug is about all questions having zero grade. I think the comment should describe the problem, not to superficial symptoms. Can you be bothered to amend it before submitting for integration?

              jamiesensei Jamie Pratt added a comment -

              I amended the commit message (on all three branches, thank goodness for mdk!).

              And I'm submitting this for integration.

              stronk7 Eloy Lafuente (stronk7) added a comment -

              Hi, Jamie, it seems the 26 branch is empty. I've cherry-picked the commit from master, hope that's ok. Ping me if not.

              Ciao

              stronk7 Eloy Lafuente (stronk7) added a comment -

              More yet, any reason for not getting it also in 24_STABLE ?

              stronk7 Eloy Lafuente (stronk7) added a comment -

              Integrated (24, 25, 26 & master). Thanks, ciao

              NOTE: I was perfectly able to reproduce it in 24_STABLE and the commit fixed the graph. And 24_STABLE is supported until end of December (next minor releases on January, to be exact).

              rajeshtaneja Rajesh Taneja added a comment -

              Thanks for fixing this Jamie,

              I can see the graph now.. Passing...

              poltawski Dan Poltawski added a comment -

              Thanks for your contributions, this change is now upstream!

              “ If debugging is the process of removing software bugs, then programming must be the process of putting them in. ” - Edsger Dijkstra


                People

                • Votes:
                  0 Vote for this issue
                  Watchers:
                  5 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    13/Jan/14