Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-43169

Introduce calendar type choice at system level (Backport of MDL-42932)

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.6
    • Fix Version/s: 2.6.2
    • Component/s: Calendar
    • Labels:
    • Testing Instructions:
      1. Install the calendar type 'test' (https://github.com/markn86/moodle-calendartype_test) into the folder calendar/type/test.
      2. Visit admin/index.php and install the 'test' calendar.
      3. Visit <yoursite>/admin/settings.php?section=calendar and set the calendar type default to 'test' (it should be 'gregorian' by default').
      4. Enable self registration.
      5. Create a user using the registration steps and ensure that the calendar type set for their profile is 'test'.
      6. Create a user using the web service functionality and ensure the calendar type in their profile is 'test'.
      7. Log in using the DB authentication plugin and ensure the user is created with the 'test' calendar type.
      Show
      Install the calendar type 'test' ( https://github.com/markn86/moodle-calendartype_test ) into the folder calendar/type/test. Visit admin/index.php and install the 'test' calendar. Visit <yoursite>/admin/settings.php?section=calendar and set the calendar type default to 'test' (it should be 'gregorian' by default'). Enable self registration. Create a user using the registration steps and ensure that the calendar type set for their profile is 'test'. Create a user using the web service functionality and ensure the calendar type in their profile is 'test'. Log in using the DB authentication plugin and ensure the user is created with the 'test' calendar type.
    • Affected Branches:
      MOODLE_26_STABLE
    • Fixed Branches:
      MOODLE_26_STABLE
    • Sprint:
      BACKEND Sprint 8
    • Sprint:
      BACKEND Sprint 8

      Description

      I don't see any reason why this useful feature shouldn't be backported.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              samhemelryk Sam Hemelryk added a comment -

              Just noting I've added this to the list of issues to consider for backporting.
              Once enough votes have come in we'll be able to act upon this.

              samhemelryk Sam Hemelryk added a comment -

              Aha my apologies, its being a while since I've dealt with a backport request.
              This must wait at least three weeks before being backported Mark in order to let any regressions come to the surface in master.

              I'm going to add the integration_held label to keep this out of our immediate queue and it will appear magically after that 3 week period on our dashboard.

              markn Mark Nelson added a comment -

              Thanks Sam!

              ankit_frenz Ankit Agarwal added a comment -

              Not sure if we should backport this, since the patch has code style fixes and changes a few public apis.

              Gets -1 from me.

              poltawski Dan Poltawski added a comment -

              I've not looked at this at all yet, but just seen Ankits comments whilst pulling into integration. Mark, you might want to eliminate the coding style fixes to increase your chances of success.

              poltawski Dan Poltawski added a comment -

              The integration team is considering this backport request right now. Stay tuned!

              stronk7 Eloy Lafuente (stronk7) added a comment -

              This backport request has been voted on by integrators, and we'd like to see it backported asap.

              Thanks!

              stronk7 Eloy Lafuente (stronk7) added a comment -

              (sending this back to development, just in case there is anything to do, rebase, clean...)

              stronk7 Eloy Lafuente (stronk7) added a comment -

              Side note: In the review process if was commented that, perhaps, the webservice change should not be applied to stable branches. For your knowledge/consideration.

              markn Mark Nelson added a comment -

              Hey Eloy, I have rebased this. I do not think it is an issue to include the web service changes in the stable branches. If the calendar type is not specified in the web service call then the default is chosen, so backwards compatibility isn't an issue afaics.

              stronk7 Eloy Lafuente (stronk7) added a comment -

              The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week.

              TIA and ciao

              cibot CiBoT added a comment -

              Moving this issue to current integration cycle, will be reviewed soon. Thanks for the hard work!

              markn Mark Nelson added a comment -

              I just thought, what if the calendar type was specified in the web service BUT the site they were communicating with was using an older version of the stable branch which did not specify this variable? I am removing the changes in user/externallib.php to ensure this won't break the call.

              damyon Damyon Wiese added a comment -

              Thanks Mark,

              Looks perfect - I agree with not changing the web service (I think I raised it).

              Integrated to 26 only.

              Cheers!

              fred Frédéric Massart added a comment -

              Passing, thanks.

              stronk7 Eloy Lafuente (stronk7) added a comment -

              I claim to be a simple individual
              liable to err like any other fellow mortal.
              I own, however, that I have humility enough
              to confess my errors and to retrace my steps.

              Mahatma Gandhi

              Your awesome code has met upstream, closing, thanks!

              marycooch Mary Cooch added a comment -

                People

                • Votes:
                  2 Vote for this issue
                  Watchers:
                  7 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    10/Mar/14