Moodle
  1. Moodle
  2. MDL-43258

Style coursebox info name better in Bootstrap themes

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.5.3
    • Fix Version/s: 2.5.4
    • Component/s: Themes
    • Labels:
    • Testing Instructions:

      Only 2.5 is changed:

      1. Select Clean theme
      2. Go to Front Page and Edit setting to enable both Combo (Course/Category list) and Courses list
      3. Make sure you have some courses in the system and some of them has some enrolment methods other than manual
      4. Test that each 'course' name listed sits on a single line below their respective categories. Very long titles will wrap, but relatively shorter ones shouldn't, which is what this patch aims to fix.
      Show
      Only 2.5 is changed: Select Clean theme Go to Front Page and Edit setting to enable both Combo (Course/Category list) and Courses list Make sure you have some courses in the system and some of them has some enrolment methods other than manual Test that each 'course' name listed sits on a single line below their respective categories. Very long titles will wrap, but relatively shorter ones shouldn't, which is what this patch aims to fix.
    • Affected Branches:
      MOODLE_25_STABLE
    • Fixed Branches:
      MOODLE_25_STABLE

      Description

      The coursebox info name looks all squashed up in Clean theme in Moodle 2.5.

      Link to forum discussion about same issue:
      https://moodle.org/mod/forum/discuss.php?d=245388#p1064257

        Gliffy Diagrams

          Issue Links

            Activity

            Marina Glancy added a comment -

            Thanks Mary. Now 2.5 looks better than 2.6.... The only thing is that you are not allowed to push coding style changes in stable version so can you please undo the "center left"->"left center" changes and whitespaces.

            This asynchronous fixing of headings, styles and etc. is just frustrating sometimes. Please can you look at this issue together with Rossiani Wijaya. In 2.6 the
            ".coursebox > .info > h3.coursename" does not have "float:left" which results in the enrolment icons being displayed on the next line.

            I attach screenshots in 25stable, 25mary (with this change) and 26stable

            Mary Evans added a comment -

            Hi Marina,

            With regards to the changes I made from 'center left' to 'left center' is a CSS CORRECTION the way it was added is wrong as it should be written as an (x, y) coordinate and NOT (y, x) as it is now. It's rather like how borders have been written in some areas of Moodle eg: border: red solid 1px; where in truth it should read eg: border: 1px solid red;

            Things like this need fixing so how can I do that correctly in Moodle?

            As for 2.6 I tried changing the h3 headers but it was rejected because things like the headers need to be discussed, apparently. Meetings are nothing more than excuses to delay issues. I got so cross I closed the issue and went off in a sulk!

            But for the sake of my sanity will work with Rossi and get Bootstrap themes fixed too. Is there a tracker for that or should I open a new on?

            Marina Glancy added a comment -

            Hi Mary,

            if you are saying that CSS "background-position:center left;" is a bug and can work incorrectly in some browsers, we need to create a separate issue for it and fix in all supported versions (2.4-master) and not just in 2.5. If it is not a bug, it can only go in master. This is an integration rule, I'm sorry.

            There is no tracker issue regarding enrolment icons I suppose and it looks pretty reasonable to fix it in this issue. As I see it we just need to add
            .coursebox > .info > h3.coursename

            { float: left; }
            Mary Evans added a comment -

            I'll work on new branches and fix both 2.5 and 2.6.

            Mary Evans added a comment -

            So I don't forget these are the changes need in 2.6

            .coursename, h3.categoryname {float: left; clear: left;}
            .coursebox > .info > .coursename a {background-position: 0 0.3em;}
            .coursebox > .info > h3.coursename a {background-position: 0 0.5em;}
            

            Mary Evans added a comment -

            @Marina, I have fixed the problems you asked me to fix. Squashed and resubmitted.

            Marina Glancy added a comment -

            Thanks Mary, integrated in 2.5

            I will create another issue for enrolment icons in 2.6. If you make the style changes together with the bug please make sure to put them in the separate commit. Thanks again

            Marina Glancy added a comment -

            Issue for 2.6 MDL-43321

            Damyon Wiese added a comment -

            Looks OK to me. Passing the test. Thanks Mary!

            Mary Evans added a comment -

            Thanks D

            Sam Hemelryk added a comment -

            Thanks for the code, its now upstream!

            Heres a fun trick to try in the spirit of Friday the 13th.
            I hear if you stand in front a mirror, alone, in the dark, and say "Oracle" three times Petr Skoka will appear in the mirror and you'll see him deleting the Oracle driver from Moodle.


              People

              • Votes:
                1 Vote for this issue
                Watchers:
                7 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: