Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-43277

Long activity names, inconsistent shortening

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.4.7, 2.5.3, 2.6, 2.7
    • Fix Version/s: 2.5.6, 2.6.3
    • Component/s: Navigation
    • Labels:
    • Testing Instructions:
      Hide
      1. Open a course and turn editing on
      2. Edit an existing activity to give it a really long name (I went for a song lyric)
      3. Refresh the page
      4. Expand the relevant section in the 'Navigation' block
        • Confirm that the name has been shortened with the ... on the right-hand side
      5. Enter the activity
      6. Looking at both:
        1. the navigation block; and
        2. the breadcrumb
        • Confirm that the name has been shortened with the ... on the right-hand side
      Show
      Open a course and turn editing on Edit an existing activity to give it a really long name (I went for a song lyric) Refresh the page Expand the relevant section in the 'Navigation' block Confirm that the name has been shortened with the ... on the right-hand side Enter the activity Looking at both: the navigation block; and the breadcrumb Confirm that the name has been shortened with the ... on the right-hand side
    • Affected Branches:
      MOODLE_24_STABLE, MOODLE_25_STABLE, MOODLE_26_STABLE, MOODLE_27_STABLE
    • Fixed Branches:
      MOODLE_25_STABLE, MOODLE_26_STABLE
    • Pull Master Branch:
      MDL-43277-master

      Description

      When long activity names are introduced, a shortened version is shown both in the navigation block and breadcrumb.

      It seems that the shortening is being applied inconsistently:

      1) In course pages, it's Right-shortening. Correct. course_page.png
      2) In module pages, it's Left-shortening. Incorrect. activity_page.png

      Note this also should be coherent for RTL langs, I've not verified current behavior there.

      Detected with Moodle 2.7dev, surely the same happens in stables. Here there is a (Spanish) post commenting about it happening with Moodle 2.4.7:

      https://moodle.org/mod/forum/discuss.php?d=245476

        Attachments

          Activity

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Fix Release Date:
                12/May/14