Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-43312

Upgrade TinyMCE to 3.5.10 (Fixes: links in TinyMCE are removed from HTML on insert/edit in IE)

    Details

      Description

      I'm facing a problem with TinyMCE editor in Internet Explorer 11.0.1.
      The inserted hyperlink is removed from HTML when using toolbar icon "Insert/edit link".

      Steps to reproduce:

      1) select text in editor and click on toolbar icon "Insert/edit link"

      2) enter your url and click insert button. You may notice that link is not being highlighted in editor, though toolbar icon "remove link" is activated

      3) Click "view HTML" and you may notice that HTML A tag is placed as first element of parent element, with an empty content (should be selected text).

      4) when you click again on TinyMCE editor area previously inserted A tag is removed from HTML markup

      This has been tested on Moodle 2.5 branch and on moodle.org community forums:
      https://moodle.org/mod/forum/discuss.php?d=245479

      IE10, Firefox, Chrome and Opera works as intended.

      There is another problem which might be linked to this issue. When submitting new discussion/reply form the validation triggers "Required" error on "Message" field. Second submit actually submits the form without an error.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Votes:
                  14 Vote for this issue
                  Watchers:
                  21 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    12/May/14