Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-43604

add support for MariaDB 10.x

XMLWordPrintable

    • MOODLE_26_STABLE
    • MOODLE_27_STABLE
    • w12_MDL-43604_m27_mariadb10
    • Hide

      1/ install mariadb 10.0.9 RC
      2/ configure moodle to use mariadb driver
      3/ try fresh new install - the environment page should tell you "version 5.5.31 is required and you are running 10.0.x"
      4/ you should see the raw version number in brackets in second column of the environment table

      Note: anything >=5.6 may throw extra unit test failure this will be addressed in MDL-44191

      Show
      1/ install mariadb 10.0.9 RC 2/ configure moodle to use mariadb driver 3/ try fresh new install - the environment page should tell you "version 5.5.31 is required and you are running 10.0.x" 4/ you should see the raw version number in brackets in second column of the environment table Note: anything >=5.6 may throw extra unit test failure this will be addressed in MDL-44191
    • 2

      It looks like they decided to hack version numbers in future MariaDB release, my moodle tells me now that "5.5.5-10.0.7-MariaDB" is not high enough...

      Solution is to do some stripping of extra rubbish in our mariadb driver...

        1. maria.png
          maria.png
          102 kB
        2. mariadb10.patch
          1 kB

            skodak Petr Skoda (Inactive)
            skodak Petr Skoda (Inactive)
            Damyon Wiese Damyon Wiese
            Marina Glancy Marina Glancy
            Rajesh Taneja Rajesh Taneja
            Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

              Created:
              Updated:
              Resolved:

                Error rendering 'clockify-timesheets-time-tracking-reports:timer-sidebar'. Please contact your Jira administrators.