Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-43633

[2.6] Message Course Users Fails to Work

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: 2.6
    • Fix Version/s: BACKEND
    • Component/s: Messages
    • Labels:
    • Affected Branches:
      MOODLE_26_STABLE

      Description

      From a course participants list select user, with selected users choose send message, enter your message click preview, click send message. The page sits there loading till it ends with a page that only has the header of the site.

      I started going through the code a bit and narrowed it down to send_message() in lib/messagelib.php however I could use a second set of eyes, also is anyone else experiencing this. I have a dev box with 2.5 that works fine, however, my 2.6+ my (recently upgraded over Christmas) production box seems to fail.

      This same issues seems to be caused when someone is self enrolling into a course and a welcome message is enabled.

      Thanks,

      Jason

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              jcarson@tyndale.ca Jason Carson
              Participants:
              Component watchers:
              Amaia Anabitarte, Carlos Escobedo, Ferran Recio, Ilya Tregubov, Sara Arjona (@sarjona)
              Votes:
              0 Vote for this issue
              Watchers:
              7 Start watching this issue

                Dates

                Created:
                Updated: