Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-43732

Order and Paging controls inaccessible

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.6.1
    • Fix Version/s: 2.6.2
    • Component/s: Quiz
    • Labels:
    • Testing Instructions:
      1. Create a course with a quiz in it
      2. In the quiz, add 3 questions
      3. In the Editing quiz tab, confirm that the 'Marked out of' box doesn't overlap the arrow icons.
      4. Go to the Order and paging tab
      5. Verify that you can place the cursor in the weight box to the right of a question.
      6. Confirm that the icons to the right of the box (up/down/delete) show as clickable with an associated link (you can do this by actually clicking them, but you may not want to actually remove the questions.
      7. Confirm that the icons are not covered by the text box in general. There are a few themes, namely MyMobile that still have a little overlap, but it is better than the current version.
      8. Repeat for all themes and browsers. This could probably be reduced to some a few themes each of base and bootstrap...
      Show
      Create a course with a quiz in it In the quiz, add 3 questions In the Editing quiz tab, confirm that the 'Marked out of' box doesn't overlap the arrow icons. Go to the Order and paging tab Verify that you can place the cursor in the weight box to the right of a question. Confirm that the icons to the right of the box (up/down/delete) show as clickable with an associated link (you can do this by actually clicking them, but you may not want to actually remove the questions. Confirm that the icons are not covered by the text box in general. There are a few themes, namely MyMobile that still have a little overlap, but it is better than the current version. Repeat for all themes and browsers. This could probably be reduced to some a few themes each of base and bootstrap...
    • Affected Branches:
      MOODLE_26_STABLE
    • Fixed Branches:
      MOODLE_26_STABLE
    • Pull from Repository:
      git@github.com:merrill-oakland/moodle.git
    • Pull Master Branch:

      Description

      When editing a quiz, and the Order and Paging page, the controls (up/down/remove as well as the number text field) to the right of the question are inaccessible in every theme.

        Gliffy Diagrams

          Issue Links

            Activity

            emerrill Eric Merrill added a comment -

            This was caused by the stripping of z-indexes in MDL-42692.

            I've been able to fix it by removing the position:relative from the question information container, (.questioncontentcontainer), but I'm not sure if that is the correct path.

            Adding z-indexes back with new values may make sense, but I'm not sure if that would break something that was trying to be fixed in MDL-42692.

            emerrill Eric Merrill added a comment -

            Added a few watchers based on the link to MDL-42692. Obviously feel free to remove yourself.

            emerrill Eric Merrill added a comment -

            I dug around in the code, and #page-mod-quiz-edit .reorder .questioncontentcontainer appears to only be used in this one view, so I'm confident it won't break other areas of code.

            I also moved #page-mod-quiz-edit div.question div.content div.points to the left 10px. This is because the icons got bigger, but the box was never moved, meaning that one of the icons would partially fall under the box.

            timhunt Tim Hunt added a comment -

            Thanks Eric. Submitting for integration.

            damyon Damyon Wiese added a comment -

            Hi Eric,

            Thanks for the patch - it seems to work well for ltr - but you have not added the equivalent css change for rtl. Please update the patch and I'll take another look.

            Thanks!

            emerrill Eric Merrill added a comment -

            Done. The primary change to #page-mod-quiz-edit .reorder .questioncontentcontainer fixed bot ltr and rtl, I just added the pixel adjustment for rtl.

            damyon Damyon Wiese added a comment -

            Thanks for the update Eric. Looks correct to me now.

            Integrated to 26 and master.

            fred Frédéric Massart added a comment -

            Passing. Testing on Chrome, Firefox and IE9. Everything is functional but things could look a bit better on Clean.

            stronk7 Eloy Lafuente (stronk7) added a comment -

            I won't be saying "Thanks!" this week. I'm tired of it.

            For the good (and the bad), your code is now part of Moodle, the best LMS in the world. Hope you are contributing for that to continue being a fact (and not the opposite), sincerely.

            Just closing this as fixed, ciao

            PS: Just a bit of black/cruel humor, sorry, LOL!


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                7 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  10/Mar/14