Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-43809

Multianswer export messes up $s in subquestions.

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.5.4, 2.6.1, 2.7
    • Fix Version/s: 2.5.5, 2.6.2
    • Component/s: Questions
    • Labels:
    • Testing Instructions:
      Hide

      1. Create a multianswer (Cloze) question with question text

      Example: {1:MULTICHOICE:= y,y,$3 ~ $3,y,y}

      2. Export this question (the category it is in) as Moodle XML format.

      3. View the XML file, and ensure the $3 is still present.

      Show
      1. Create a multianswer (Cloze) question with question text Example: {1:MULTICHOICE:= y,y,$3 ~ $3,y,y} 2. Export this question (the category it is in) as Moodle XML format. 3. View the XML file, and ensure the $3 is still present.
    • Affected Branches:
      MOODLE_25_STABLE, MOODLE_26_STABLE, MOODLE_27_STABLE
    • Fixed Branches:
      MOODLE_25_STABLE, MOODLE_26_STABLE
    • Pull from Repository:
    • Pull Master Branch:

      Description

      Reported here: https://moodle.org/mod/forum/discuss.php?d=252616#p1095504. It was acutally a bad preg_replace that needed a preg_quote.

        Attachments

          Activity

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Fix Release Date:
                10/Mar/14