Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-43985

Fix lack of checkbox to control feedback whe grading assignment (backport of MDL-33600)

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.3.9, 2.3.11, 2.4.6, 2.5.2, 2.5.5, 2.6.2
    • Fix Version/s: 2.5.6, 2.6.3
    • Component/s: Assignment
    • Labels:
    • Testing Instructions:
      1. Run the unit tests
      2. Grade a student in mod_assign and leave the "Notify students" checkbox checked
      3. Verify the student receives an email about updated feedback
      4. Grade a student in mod_assign and uncheck the "Notify students" checkbox
      5. Verify the student does not receive an email about updated feedback
      Show
      Run the unit tests Grade a student in mod_assign and leave the "Notify students" checkbox checked Verify the student receives an email about updated feedback Grade a student in mod_assign and uncheck the "Notify students" checkbox Verify the student does not receive an email about updated feedback
    • Affected Branches:
      MOODLE_23_STABLE, MOODLE_24_STABLE, MOODLE_25_STABLE, MOODLE_26_STABLE
    • Fixed Branches:
      MOODLE_25_STABLE, MOODLE_26_STABLE
    • Pull from Repository:

      Description

      In version 1.9, teachers could control whether or not students received notification when assignments were graded or when grades were changed. In the upgrade to version 2.X, this functionality was lost. According to MDL-33600, this will be fixed for version 2.7 which is great.

      However, not all institutions, especially larger ones like the University of Illinois will be able to upgrade to version 2.7 right away. Like is stated on the instruction page for requesting backporting of issues, "Large amounts of change on the stable branches make the lives difficult for institutions to manage upgrades between point releases."

      This is not really an improvement in Moodle functionality; rather it is restoration of functionality that was available in an earlier version and was lost when that version was upgraded. We have found that very large classes (those with several hundred students) are most affected by this lack of control over the sending of feedback to students since assignments may be graded by multiple people and at different times. Instructors often hide grades so that students will not receive access to grades at different times. Additionally, the more students in the class, the more chance there is for grade adjustments to be necessary. In short, teachers of courses should have control over whether students are notified of grade changes in their courses.

      Large institutions are more likely to have larger courses and are also less likely to install the latest and greatest Moodle code due to the issues of change management.

      So, since this is not really a new feature and because it will most likely have the greatest impact on institutions that are least likely to be able to install version 2.7 in May, it is a perfect candidate for backporting. I would request that it be backported to any versions that are currently being supported.

        Gliffy Diagrams

          Issue Links

            Activity

            mturre Michele Turre added a comment -

            UMass Amherst, also a large university, will move to 2.6 in June 2014. We do not typically do major upgrades in January. This would mean no checkbox for our instructors (who sorely miss this feature) until summer 2015. We would be very happy to see this backported.

            rexj Jedidiah Rex added a comment -

            I second Michele's comment. Faculty at Beloit College would love to see this back. The sooner this can be implemented the better.

            justinlitalien Justin Litalien added a comment -

            Add me to the list of interested folks. Like Michele, we'll be visiting 2.7 (or 2.8) in Summer 2015.

            russellb Russell Boyatt added a comment -

            This issue has caused some serious problems for us and resulted in us disabling assignment notifications site-wide to stop rogue notifications going to students. Even an upgrade to Moodle 2.6 this summer would mean we would be stuck with the issue for another academic year.

            I've backported this feature to Moodle 2.4. I'm sure it will need further discussion, tidying up and testing but here's a first go...

            https://github.com/rboyatt/moodle/compare/moodle:MOODLE_24_STABLE...wip-MDL-33600-MOODLE_24_STABLE

            ray Ray Lawrence added a comment -

            pretty sure this is fixed in another issue.

            russellb Russell Boyatt added a comment -

            Ray - the issue is fixed for 2.7 in MDL-33600 but I wasn't aware this has been backported to 2.4/2.5/2.6 in another issue?

            gbrewste Geoffrey Brewster added a comment -

            If this has been backported in another issue, I apologize. I didn't find it when I searched. Ray, do you know the issue # to which you are referring?

            joemurphy Joe Murphy added a comment - - edited

            Another school (Kenyon College) reporting in which is looking at 2.6 for Summer 2014, and would love to get this feature before Summer 2015.

            russellb Russell Boyatt added a comment -

            Here is a first go at backporting the changes to Moodle 2.6. Be warned: I've not tested extensively!

            https://github.com/rboyatt/moodle/compare/MOODLE_26_STABLE...wip-MDL-33600-MOODLE_26_STABLE

            aquisse Thomas Hanley added a comment -

            This issue has given my university (City University London) alot of headaches also! Main issue being students being confused when receiving the notifications and then finding that they cannot view feedback as grades not released (this despite us changing the language in the emails!). We are planning a move to Moodle 2.6 in May, so would appreciate a backport.
            Russell: thanks for your effort in backporting for 2.6!

            damyon Damyon Wiese added a comment -

            The integration team is considering this backport request right now. Stay tuned!

            poltawski Dan Poltawski added a comment -

            This backport request has been voted on by integrators, and we'd like to see it backported asap.

            Thanks to all the voters on this issue, as you made it absolutely clear to us that you value this change being backported.

            damyon Damyon Wiese added a comment -

            I'll make a version of this patch that does not rely on DB changes for the backport.

            aquisse Thomas Hanley added a comment -

            This is good news and much appreciated by staff at my university. Many thanks Damyon and Dan and everyone who voted.

            gbrewste Geoffrey Brewster added a comment -

            Thank you to all the people voting for this issue. I think this will make the lives of Moodlers worldwide easier.

            Is there a timeline on when the new code will be ready? I would also volunteer to test it when it is ready.

            aa7670 Marius Jugariu added a comment -

            Apart from the issue described above in 2.6.1 there is also the issue that when providing feedback emails go out to say that feedback has been given although it hasn't been released yet. It kind of ignores the whole point of "marking workflow" feature. And when using the marking workflow to mark them all as "released" no emails are going out. Except for knowing what is the status of a submission, the whole feature is bugged.

            salvetore Michael de Raadt added a comment -

            I've ranked this up so we don't miss it.

            damyon Damyon Wiese added a comment -

            My original patch was split in 2 commits - one for the checkbox, and one for adding the admin default. If we only take the first one (as I have done here) - then there are no DB changes required for the backport.

            cibot CiBoT added a comment -

            Moving this issue to current integration cycle, will be reviewed soon. Thanks for the hard work!

            marina Marina Glancy added a comment -

            Thanks Damyon, integrated in 2.5 and 2.6

            salvetore Michael de Raadt added a comment -

            Test result: Success!

            Tested in 2.6 and 2.5 plus master for comparison.

            stronk7 Eloy Lafuente (stronk7) added a comment -

            Clothes and manners do
            not make the man; but,
            when he is made, they
            greatly improve his appearance.

            ---- Henry Ward Beecher

            What a week, your changes are now part of Moodle, well done!

            Closing, thanks!


              People

              • Votes:
                80 Vote for this issue
                Watchers:
                38 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  12/May/14