Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-44217

The link colour in Bootstrapbase is not WCAG compliant

    XMLWordPrintable

    Details

    • Testing Instructions:
      Hide

      You need to test this on the integration branches with the Atto editor.
      (I personally would merge Atto into the integration branches before testing)

      Test 1

      1. Log into your site as an admin.
      2. Check that all links are the same colour (unless they are different in stable/master)
      3. Confirm that the link colour is inline with the theme design.
      4. Hover over any link and check that the hover colour is darker than the link colour and still fits within the design of the theme.
      5. Check several pages within Moodle.

      Test 2

      1. Log in as an admin.
      2. Turn on theme designer mode, purge caches, and clear your browser cache (or strong refresh).
      3. Edit your profile and do the following:
        • Change your editor to Atto.
        • Set your profile description to "This is a test link that I hope works" and make the work link a link to any page you want (you don't need to click it).
      4. Save the profile changes
      5. Confirm that the link colour looks good when viewing your profile (the next screen).
      6. Edit your profile again, confirm you have the Atto editor
      7. Toggle Atto to show all buttons and then click to Accessibility checker button.
      8. Confirm you don't get any accessibility warnings.
      Show
      You need to test this on the integration branches with the Atto editor. (I personally would merge Atto into the integration branches before testing) Test 1 Log into your site as an admin. Check that all links are the same colour (unless they are different in stable/master) Confirm that the link colour is inline with the theme design. Hover over any link and check that the hover colour is darker than the link colour and still fits within the design of the theme. Check several pages within Moodle. Test 2 Log in as an admin. Turn on theme designer mode, purge caches, and clear your browser cache (or strong refresh). Edit your profile and do the following: Change your editor to Atto. Set your profile description to "This is a test link that I hope works" and make the work link a link to any page you want (you don't need to click it). Save the profile changes Confirm that the link colour looks good when viewing your profile (the next screen). Edit your profile again, confirm you have the Atto editor Toggle Atto to show all buttons and then click to Accessibility checker button. Confirm you don't get any accessibility warnings.
    • Affected Branches:
      MOODLE_27_STABLE
    • Fixed Branches:
      MOODLE_25_STABLE, MOODLE_26_STABLE
    • Pull Master Branch:
      44217-27
    • Pull Master Diff URL:
    • Story Points:
      8
    • Sprint:
      FRONTEND Sprint 10

      Description

      According to the accessibility checker in Atto, in Boostrapbase/Clean the contract of the links are reported as not compliant with WCAG AA.

        Attachments

          Activity

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Fix Release Date:
                10/Mar/14