Details

    • Type: Task
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.7
    • Fix Version/s: 2.7
    • Component/s: JavaScript, Libraries
    • Labels:
    • Testing Instructions:
      1. run behat tests

      With the JS console open, and checking for errors:

      1. Test that drag/drop works as expected on:
        • blocks
        • course sections
        • course activities
      2. On an android device, ensure that when drag/dropping, the text is not also selected
      3. Open the file picker, and upload a file
        • confirm that no errors were hit on the page
      4. Open some dialogues and check that the scroll does not jump to the top of the page:
        • Chooser dialogue
        • File picker
        • Backup cancel confirmation
        • Help tooltip
      Show
      run behat tests With the JS console open, and checking for errors: Test that drag/drop works as expected on: blocks course sections course activities On an android device, ensure that when drag/dropping, the text is not also selected Open the file picker, and upload a file confirm that no errors were hit on the page Open some dialogues and check that the scroll does not jump to the top of the page: Chooser dialogue File picker Backup cancel confirmation Help tooltip
    • Affected Branches:
      MOODLE_27_STABLE
    • Fixed Branches:
      MOODLE_27_STABLE
    • Pull Master Branch:
      MDL-44361-master
    • Sprint:
      FRONTEND Sprint 9
    • Story Points (Obsolete):
      5
    • Sprint:
      FRONTEND Sprint 9

      Description

      Released this week and addressing a number of issues that we've patched in the mean-time.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              dobedobedoh Andrew Nicols added a comment -

              I've just added a commit to this - the weird and whacky way in which we supplment Y.io with additional stuff has changed in 3.15.
              I haven't quite worked out what but I will attempt to find out. I think it may be something to do with the Y.io rollup.

              skodak Petr Skoda added a comment -

              sending to integration, thanks

              cibot CiBoT added a comment -

              Moving this issue to current integration cycle, will be reviewed soon. Thanks for the hard work!

              dobedobedoh Andrew Nicols added a comment -

              Apologies - meant to comment on this before now.

              YUI 3.15.0 introduced a new sort function which broke out previous Y.io magic. Turns out that there was a much simpler way of doing this, and which we should have used originally. The way we were doing things was bass ackwards and is unsupported.

              I don't intend to backport the javascript-static change because the current version does work, and I'd rather not start changing loader configurations on a stable branch.

              skodak Petr Skoda added a comment -

              oh, it is great that you have found this problem before the freeze, thanks!

              damyon Damyon Wiese added a comment -

              Commenting to say that I am waiting on some more testing instructions that tests the actual changed functionality between the 2 versions. I think our use of yui is growing and we will need to test yui updates more and more.

              dobedobedoh Andrew Nicols added a comment -

              I've added additional testing instructions based on the release notes (https://github.com/yui/yui3/wiki/YUI-3.15.0-Change-History-Rollup).
              It's not possible to test every major change (we don't use all of those components), and we already had many of the issues fixed locally.

              damyon Damyon Wiese added a comment -

              In testing this I found: MDL-44456 Grrr....

              damyon Damyon Wiese added a comment -

              I've integrated this now. I tested it before integrating.

              I found the above issue with editpdf (not caused by this issue).

              Also drag and drop on android can be made to work by fiddling - but really I would consider it broken and unusable. We should disable it completely IMO.

              damyon Damyon Wiese added a comment -

              Tested in integration.

              I haven't run behat - will rely on CI for that. If it fails in CI I'll fail this issue.

              dobedobedoh Andrew Nicols added a comment -

              Not having access to an Android device personally really hampers my ability to work on that :\
              Just another example of why Android sucks

              damyon Damyon Wiese added a comment -

              ci behat has passed with this issue integrated. Passing!

              stronk7 Eloy Lafuente (stronk7) added a comment -

              For fun: http://www.youtube.com/watch?v=IGENkpaPkgw

              Many thanks for your hard work, this is now part of Moodle!

              Ciao


                People

                • Votes:
                  0 Vote for this issue
                  Watchers:
                  4 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    12/May/14