Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-4451

Admin Block not valid XHTML on course pages

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.5
    • Fix Version/s: None
    • Component/s: Blocks
    • Labels:
      None
    • Environment:
      Windows XP

      Description

      I found this problem on a live version running 1.5.2, and a local version running 1.5.3. On a course page the Admin Block does not validate as XHTML because one of the image elements is not self-closing - the home page works OK. The problem appears on line 124 of my block_admin.php:

      $this->content->icons[]='<img src='.$CFG->pixpath.'/i/users.gif height=16 width=16 alt=>';

      should be

      $this->content->icons[]='<img src='.$CFG->pixpath.'/i/users.gif height=16 width=16 alt= />';

        Gliffy Diagrams

          Activity

          Hide
          dougiamas Martin Dougiamas added a comment -

          From Jon Papaioannou (pj at moodle.org) Wednesday, 7 December 2005, 11:03 PM:

          Fixed in HEAD and STABLE.

          Show
          dougiamas Martin Dougiamas added a comment - From Jon Papaioannou (pj at moodle.org) Wednesday, 7 December 2005, 11:03 PM: Fixed in HEAD and STABLE.
          Hide
          mblake Michael Blake added a comment -

          Temporary transition to reassign bug to "pj".

          Show
          mblake Michael Blake added a comment - Temporary transition to reassign bug to "pj".
          Hide
          mblake Michael Blake added a comment -

          Re-closing bugs after re-assigning to "pj".

          Show
          mblake Michael Blake added a comment - Re-closing bugs after re-assigning to "pj".

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: