Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-44759

Atto Undo starts highlighted on an empty field

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.7
    • Fix Version/s: 2.7
    • Component/s: HTML Editor (Atto)
    • Labels:
    • Testing Instructions:
      Hide
      1. Open Atto and check the undo/redo plugins
      2. Make sure
        • It does not start with undo enabled
        • Undoing steps works, as well as redoing them
        • The redo option disappears when you add content
        • That it works as you'd expect it

      For now, steps are only saved when you use the arrow keys or move the cursor with the mouse.

      Show
      Open Atto and check the undo/redo plugins Make sure It does not start with undo enabled Undoing steps works, as well as redoing them The redo option disappears when you add content That it works as you'd expect it For now, steps are only saved when you use the arrow keys or move the cursor with the mouse.
    • Affected Branches:
      MOODLE_27_STABLE
    • Fixed Branches:
      MOODLE_27_STABLE
    • Pull from Repository:
    • Pull Master Branch:
      MDL-44759-master
    • Story Points:
      5
    • Sprint:
      FRONTEND Sprint 11

      Description

      This is because we insert <p></p> behind the scenes, but it gets caught in the undo stack. I think treating <p></p> as '' in the undo plugin would fix this.

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  12/May/14