Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-45070

add support for MariaDB 10.x from Ubuntu

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.6
    • Fix Version/s: 2.7
    • Component/s: Database SQL/XMLDB
    • Labels:
    • Testing Instructions:
      Hide

      1/ install mariadb 10.0.10 in Ubuntu Saucy
      2/ configure moodle to use mariadb driver
      3/ try fresh new install - the environment page should tell you "version 5.5.31 is required and you are running 10.0.10"
      4/ you should see the raw version number in brackets in second column of the environment table

      Show
      1/ install mariadb 10.0.10 in Ubuntu Saucy 2/ configure moodle to use mariadb driver 3/ try fresh new install - the environment page should tell you "version 5.5.31 is required and you are running 10.0.10" 4/ you should see the raw version number in brackets in second column of the environment table
    • Affected Branches:
      MOODLE_26_STABLE
    • Fixed Branches:
      MOODLE_27_STABLE
    • Pull from Repository:
    • Pull Master Branch:
      w16_MDL-45070_m27_ubuntumaria
    • Story Points:
      2

      Description

      Ubuntu is using a bit more complex database version - "5.5.5-10.0.10-MariaDB-1~saucy-log" - we need to relax the regex a bit.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              skodak Petr Skoda
              Reporter:
              skodak Petr Skoda
              Peer reviewer:
              Jetha Chan
              Integrator:
              Damyon Wiese
              Tester:
              Damyon Wiese
              Participants:
              Component watchers:
              Andrew Nicols, Jun Pataleta, Michael Hawkins, Shamim Rezaie, Simey Lameze
              Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Fix Release Date:
                12/May/14