Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-45075

Creating forum with 'Subscription Mode' set to 'Auto subscription' throw error.

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 2.7
    • Fix Version/s: 2.7
    • Component/s: Forum
    • Labels:

      Description

      Steps to reproduce:

      1. Log in as teacher
      2. Create forum with 'Subscription Mode' set to 'Auto subscription'
      3. Save and you will see following error

        Debug info: SELECT id,course FROM {course_modules} WHERE id IS NULL
        [array (
        )]
        Error code: invalidrecord
        Stack trace:
        line 1451 of /lib/dml/moodle_database.php: dml_missing_record_exception thrown
        line 1427 of /lib/dml/moodle_database.php: call to moodle_database->get_record_select()
        line 7074 of /lib/accesslib.php: call to moodle_database->get_record()
        line 4832 of /mod/forum/lib.php: call to context_module::instance()
        line 132 of /mod/forum/lib.php: call to forum_subscribe()
        line 113 of /course/modlib.php: call to forum_add_instance()
        line 268 of /course/modedit.php: call to add_moduleinfo()
        

        Alternatively run: MDLQA-6700 Step 5

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                7 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  12/May/14