Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-4535

negative score for quiz questions clipped

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Duplicate
    • Affects Version/s: 1.5.2
    • Fix Version/s: None
    • Component/s: Administration
    • Labels:
      None
    • Environment:
      All
    • Affected Branches:
      MOODLE_15_STABLE

      Description

      The stock 1.5.2 does not allow negative scores for individual questions or entire quizzes. In other words, it is impossible to use SAT or GRE style point assignments, in which a wrong answer is worth -0.25 points.

      A fix is proposed as follows (for 1.5.2):

      change line 864 of mod/quiz/locallib.php from

      0.0), 1.0) * $question->maxgrade;

      to

      1.0), 1.0) * $question>maxgrade;

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              imported Imported created issue -
              mblake Michael Blake made changes -
              Field Original Value New Value
              Assignee Martin Dougiamas [ martindougiamas ] Martin Dougiamas [ dougiamas ]
              dougiamas Martin Dougiamas made changes -
              Status In Progress [ 3 ] Open [ 1 ]
              poltawski Dan Poltawski made changes -
              Assignee Martin Dougiamas [ dougiamas ] Dan Poltawski [ poltawski ]
              poltawski Dan Poltawski made changes -
              Link This issue duplicates MDL-1647 [ MDL-1647 ]
              poltawski Dan Poltawski added a comment -

              Closing as duplicate of MDL-1647

              poltawski Dan Poltawski made changes -
              Status Open [ 1 ] Closed [ 6 ]
              Resolution Duplicate [ 3 ]
              dougiamas Martin Dougiamas made changes -
              Workflow jira [ 15216 ] MDL Workflow [ 51681 ]
              dougiamas Martin Dougiamas made changes -
              Workflow MDL Workflow [ 51681 ] MDL Full Workflow [ 80792 ]

                People

                • Votes:
                  0 Vote for this issue
                  Watchers:
                  0 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: