Moodle
  1. Moodle
  2. MDL-4544

Export GIFT - Format - Wrong download Link

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.5.3
    • Fix Version/s: None
    • Component/s: Quiz
    • Labels:
      None
    • Environment:
      All
    • Affected Branches:
      MOODLE_15_STABLE
    • Rank:
      11154

      Description

      When exporting a quiz with the GIFT Format to a File, its saved in the english version to directory: quiz. In the german version its saved to Test, because this name is used for a quiz. BUT the downloadlink points to quiz. An error occures, when yout try to download that file.

      Thanks

      Peter

        Activity

        Hide
        Martin Dougiamas added a comment -

        From Gustav Delius (gwd2 at york.ac.uk) Tuesday, 14 February 2006, 07:41 AM:

        Howard, here is a duplicate of the bug I recently assigned to you because I believe you already fixed it, right?

        From Gustav Delius (gwd2 at york.ac.uk) Saturday, 18 February 2006, 09:18 PM:

        See also discussion in http://moodle.org/mod/forum/discuss.php?d=37085

        From Howard Miller (howard.miller at udcf.gla.ac.uk) Tuesday, 21 February 2006, 01:00 AM:

        I thought this was fixed in 1.5.2. Can you confirm that you are still seeing the problem in 1.5.3 as you have reported?

        From (moodle at martignoni.net) Tuesday, 28 February 2006, 04:08 PM:

        This is not fixed as of 1.5.3, though it doesn't occur if the appropriate string in the lang file is not translated, i.e. $string['exportfilename'] remains quiz.

        As mentionned here: http://moodle.org/mod/forum/discuss.php?d=37085, I suggest to kick this string out of the way.

        From Howard Miller (howard.miller at udcf.gla.ac.uk) Wednesday, 22 March 2006, 12:50 AM:

        Fixed in CVS.

        Already sorted in 1.6 as this code is now different there.

        Show
        Martin Dougiamas added a comment - From Gustav Delius (gwd2 at york.ac.uk) Tuesday, 14 February 2006, 07:41 AM: Howard, here is a duplicate of the bug I recently assigned to you because I believe you already fixed it, right? From Gustav Delius (gwd2 at york.ac.uk) Saturday, 18 February 2006, 09:18 PM: See also discussion in http://moodle.org/mod/forum/discuss.php?d=37085 From Howard Miller (howard.miller at udcf.gla.ac.uk) Tuesday, 21 February 2006, 01:00 AM: I thought this was fixed in 1.5.2. Can you confirm that you are still seeing the problem in 1.5.3 as you have reported? From (moodle at martignoni.net) Tuesday, 28 February 2006, 04:08 PM: This is not fixed as of 1.5.3, though it doesn't occur if the appropriate string in the lang file is not translated, i.e. $string ['exportfilename'] remains quiz. As mentionned here: http://moodle.org/mod/forum/discuss.php?d=37085 , I suggest to kick this string out of the way. From Howard Miller (howard.miller at udcf.gla.ac.uk) Wednesday, 22 March 2006, 12:50 AM: Fixed in CVS. Already sorted in 1.6 as this code is now different there.

          People

          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: