Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Trivial Trivial
    • Resolution: Fixed
    • Affects Version/s: 1.5.3
    • Fix Version/s: 1.5.4
    • Component/s: HTML Editor (TinyMCE)
    • Labels:
      None
    • Environment:
      All
    • Affected Branches:
      MOODLE_15_STABLE
    • Fixed Branches:
      MOODLE_15_STABLE
    • Rank:
      28112

      Description

      The HTML Editor does not enlarge correctly on Firefox 1.5

      On lower versions of Firefox (Windows && Linux) it runs fine,

      it seems to me a Javascript problem (or a Firefox bug?)

      To replicate this problemjust try to edit your site settings and click to the enlarge button on the Front page Description editor.

        Activity

        Hide
        Martin Dougiamas added a comment -

        From Christian Lebe (christian at moodle.com) Tuesday, 10 January 2006, 11:19 AM:

        I can see the problem. I tried to search the htmlarea forum, but couldnt find anything.

        I have posted a question in their forum (http://www.htmlarea.com/forum/WYSIWYG_Forums_C5/WYSIWYG_Editor_Discussion_F28/)

        hopefully will get something very soon.

        From (agomez at icesi.edu.co) Wednesday, 11 January 2006, 03:36 AM:

        I've got the same problem with Internet Explorer!

        From Steve Garcia (sgarcia at bak.rr.com) Thursday, 26 January 2006, 04:44 AM:

        I looked in Mozilla's bugzilla and found a bug report for this. It appears to be a problem in HTMLarea, but one of the comments in the bug report had a workaround.

        https://bugzilla.mozilla.org/show_bug.cgi?id=301869

        In the file /lib/editor/htmlarea.php:

        In HTMLArea.cloneObject = function(obj)

        This:

        if (obj.constructor.toString().indexOf(function Function() == 1) {

        you should change into this:

        if (obj.constructor.toString().indexOf(function Function() >= 0) {

        and

        This:

        if (obj.constructor.toString().indexOf(function Array() == 1) {

        you should change into this:

        if (obj.constructor.toString().indexOf(function Array() >= 0) {

        Make the same changes in lib/editor/popups/fullscreen.php. This seems to work fine with all versions of Firefox and with IE as well.

        From Janne Mikkonen (janne.mikkonen at julmajanne.com) Thursday, 26 January 2006, 07:51 AM:

        SGarcia's fix added to Moodle stable and head. Many thanks

        I'm marking it Fixed.

        Show
        Martin Dougiamas added a comment - From Christian Lebe (christian at moodle.com) Tuesday, 10 January 2006, 11:19 AM: I can see the problem. I tried to search the htmlarea forum, but couldnt find anything. I have posted a question in their forum ( http://www.htmlarea.com/forum/WYSIWYG_Forums_C5/WYSIWYG_Editor_Discussion_F28/ ) hopefully will get something very soon. From (agomez at icesi.edu.co) Wednesday, 11 January 2006, 03:36 AM: I've got the same problem with Internet Explorer! From Steve Garcia (sgarcia at bak.rr.com) Thursday, 26 January 2006, 04:44 AM: I looked in Mozilla's bugzilla and found a bug report for this. It appears to be a problem in HTMLarea, but one of the comments in the bug report had a workaround. https://bugzilla.mozilla.org/show_bug.cgi?id=301869 In the file /lib/editor/htmlarea.php: In HTMLArea.cloneObject = function(obj) This: if (obj.constructor.toString().indexOf(function Function() == 1) { you should change into this: if (obj.constructor.toString().indexOf(function Function() >= 0) { and This: if (obj.constructor.toString().indexOf(function Array() == 1) { you should change into this: if (obj.constructor.toString().indexOf(function Array() >= 0) { Make the same changes in lib/editor/popups/fullscreen.php. This seems to work fine with all versions of Firefox and with IE as well. From Janne Mikkonen (janne.mikkonen at julmajanne.com) Thursday, 26 January 2006, 07:51 AM: SGarcia's fix added to Moodle stable and head. Many thanks I'm marking it Fixed.
        Hide
        Michael Blake added a comment -

        assign to a valid user

        Show
        Michael Blake added a comment - assign to a valid user

          People

          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: