Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 2.5.6, 2.6.3, 2.7
    • Fix Version/s: 2.6.4, 2.7.1
    • Component/s: SCORM
    • Testing Instructions:

      Create a SCORM package in your course and test with the following settings
      (use a scorm that provides a complete status - Fruit quiz is a good one)
      Test 1
      Use the following settings:
      Number of attempts: Unlimited
      Force new attempt: Yes
      Student skip content structure: Always
      Display package: New Window
      Enter the SCORM as a student (not admin/teacher)
      Complete the SCORM - make sure lesson_status is complete or passed.
      Enter the SCORM again and make sure it generates a new attempt.

      Test 2
      Use the following settings:
      Number of attempts: Unlimited
      Force new attempt: Yes
      Student skip content structure: First Access
      Display package: New Window
      Enter the SCORM as a student (not admin/teacher)
      On first entry it should open popup immediately - complete this attempt by answering all questions correctly and make sure it provides a lesson_status of complete or passed.
      Enter the SCORM again (If first entry was completed) it should display scorm/view.php to student with form to allow entry but no "checkbox" to "start new attempt", Enter SCORM and make sure it generates a new attempt.

      Test 3
      Use the following settings:
      Number of attempts: Unlimited
      Force new attempt: Yes
      Student skip content structure: Always
      Display package: current Window
      Enter the SCORM as a student (not admin/teacher)
      Complete the SCORM - make sure lesson_status is complete or passed.
      Enter the SCORM again and make sure it generates a new attempt.

      Test 4
      Use the Single Activity Course format and the following settings in your SCORM:
      Number of attempts: Unlimited
      Force new attempt: Yes
      Student skip content structure: First Access
      Display package: New Window
      Enter the SCORM as a student (not admin/teacher)
      On first entry it should open popup immediately - complete this attempt by answering all questions correctly and make sure it provides a lesson_status of complete or passed.
      Enter the SCORM again (If first entry was completed) it should display scorm/view.php to student with form to allow entry but no "checkbox" to "start new attempt", Enter SCORM and make sure it generates a new attempt.
      NOTE: The skipview setting only applies to students - if skipview is set and a teacher/admin is logged in it reacts as if skipview is set to never - this is historically because the view.php page was the only navigation point to allow a teacher to access SCORM reports.

      Show
      Create a SCORM package in your course and test with the following settings (use a scorm that provides a complete status - Fruit quiz is a good one) Test 1 Use the following settings: Number of attempts: Unlimited Force new attempt: Yes Student skip content structure: Always Display package: New Window Enter the SCORM as a student (not admin/teacher) Complete the SCORM - make sure lesson_status is complete or passed. Enter the SCORM again and make sure it generates a new attempt. Test 2 Use the following settings: Number of attempts: Unlimited Force new attempt: Yes Student skip content structure: First Access Display package: New Window Enter the SCORM as a student (not admin/teacher) On first entry it should open popup immediately - complete this attempt by answering all questions correctly and make sure it provides a lesson_status of complete or passed. Enter the SCORM again (If first entry was completed) it should display scorm/view.php to student with form to allow entry but no "checkbox" to "start new attempt", Enter SCORM and make sure it generates a new attempt. Test 3 Use the following settings: Number of attempts: Unlimited Force new attempt: Yes Student skip content structure: Always Display package: current Window Enter the SCORM as a student (not admin/teacher) Complete the SCORM - make sure lesson_status is complete or passed. Enter the SCORM again and make sure it generates a new attempt. Test 4 Use the Single Activity Course format and the following settings in your SCORM: Number of attempts: Unlimited Force new attempt: Yes Student skip content structure: First Access Display package: New Window Enter the SCORM as a student (not admin/teacher) On first entry it should open popup immediately - complete this attempt by answering all questions correctly and make sure it provides a lesson_status of complete or passed. Enter the SCORM again (If first entry was completed) it should display scorm/view.php to student with form to allow entry but no "checkbox" to "start new attempt", Enter SCORM and make sure it generates a new attempt. NOTE: The skipview setting only applies to students - if skipview is set and a teacher/admin is logged in it reacts as if skipview is set to never - this is historically because the view.php page was the only navigation point to allow a teacher to access SCORM reports.
    • Affected Branches:
      MOODLE_25_STABLE, MOODLE_26_STABLE, MOODLE_27_STABLE
    • Fixed Branches:
      MOODLE_26_STABLE, MOODLE_27_STABLE
    • Pull 2.7 Branch:
      m27_MDL-45726
    • Pull Master Branch:
      master_MDL-45726

      Description

      In a course we have a scorm 1.2 activity that is made of more items.
      When a user starts the activity and comlete the first item the item is set to completed and a green flag ii putted on it.
      After some items are completed (randomly once is 3 another time 5 another 23..) the attempt is opened in review mode and not in browse mode.
      The user cannot go on on his activity because the review mode is read noly and the items are no more marked as incomplete or completed and remains blank.
      In the DB we can find a record for the sco in mdl_scorm_scoes_track but only with the start time of the sco attempt (x.start.time and the timestamp) and we do not have the record with the cmi.core.lesson_status and cmi.core.total_time)
      The activity is set with ons single attempt, we have set the passing score in the gradebook at the 100% (we have putted in the same number of the learning objects).
      We have tried with the force completion and also with the infinite attempts, but the bug still occur.
      One other problem is that the attempt is locked for the user that no more sees the browse mode. The only way to reset is to start a new attempt from scratch or delete the attempt.
      Our sorm modules are built with a variable number of scoes (from 10 to 50).
      In moodle 1.9 and 2.3 in other intallations we do not suffer the issue with the same scorm package.
      In this Moodle 2.6.2+ (Build: 20140417) we do not know how to save our students!

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              danmarsden Dan Marsden added a comment -

              Hi Carlo, for us to look into this we need a few more things from you.

              1. A publicly accessible simple SCORM package that allows us to reproduce the issue.
              2. Full steps on how to reliably reproduce the issue with your SCORM package - including Browser versions you have tested.
              3. SCORM debugging log with what happens while you use the package and it enters review mode.
              4. (optional) - a video capture of you using your SCORM package and reproducing the issue.

              thanks,

              danmarsden Dan Marsden added a comment -

              I had someone else talk to me about this today - looks like this fixes it:

              --- a/mod/scorm/lib.php
              +++ b/mod/scorm/lib.php
              @@ -1563,7 +1563,7 @@ function scorm_check_mode($scorm, &$newattempt, &$attempt,
                   if ($incomplete === true) {
                       // The option to start a new attempt should never have been presented. 
                       $newattempt = 'off';
              -    } else if (($attempt !== '1') && !empty($scorm->forcenewattempt)) {
              +    } else if (!empty($scorm->forcenewattempt)) {
                       // A new attempt should be forced for already completed attempts.
                       $newattempt = 'on';
                   }
              

              I'll try to get a fix for this in this week

              stronk7 Eloy Lafuente (stronk7) added a comment -

              The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week.

              TIA and ciao

              ccomincini Carlo Comincini added a comment -

              Hi Dan, thankyou for reply.
              We have installed the new weekly version and upgraded to 2.7.
              The problem still occur, or the attempt of my student is locked in review mode.
              So reply to your questions, but ask you before this:
              Is there any way to unlock an attempt that is in review mode?

              Where in the db Can I change this attempt status?
              If you look at the video here: http://p-learning.com/download/problema_moodle.mp4 you will see that the attempt is at the middle of the scorm but it is locked in review mode also if not completed.
              The video shows you that the scorm is in review mode for that user, but the scorm is incomplete (22/45 is the grade)
              The video shows you that the DB has tracked the scoes not properly. we have only one record not thr three needed.
              This should reply to your 4(optional) answer.

              Point 1 - you can find the scorm that give the problem here: http://p-learning.com/download/CE_1-2.zip This is the same we use on a moodle 1.9x installation that we cannot update and that is working properly
              Point 2 - we have tested with chrome, firefox and safari, and with ie on a PC. All browsers updated at last version. We have set the SCORM as single attemtp, and in the gradebook the pass grade is 45 (the number of learning objects)
              Point 3 - le me know how to give you scorm debugging logs.

              If you need an access to the moodlei installation you can write me privately on c.comincini@p-leanring.com
              Thankyou for helping.

              danmarsden Dan Marsden added a comment -

              Hi Carlo - this fix hasn't landed in Moodle core yet but is up for review this coming week - are you able to apply the patch linked here to your site to see if it resolves your issues?

              The only way to easily unlock the attempt (without this patch in place) is to delete the existing attempt that has caused the lock.

              It may also be important to note that if your SCORM package passes a lesson_status of passed, completed, or failed then the attempt is finished as a grading event has occurred. Any attempts to re-enter that same attempt will be placed into review mode. The bug that the patch above fixes allows a new attempt to be generated correctly if the previous attempt was finished - the code wasn't generating a new attempt automatically under some circumstances and was forcing the user into the previous attempt in review mode.

              ccomincini Carlo Comincini added a comment -

              Hi Dan, thankyou for assistance.
              The patche has not effect on the attempt already in review.

              In other forums and in the moodle guidelines and also in my experience (I use moodle since 2002), the scorm package should turn from browse to review mode when the attempt reach the passing score set in the gradebook.
              In moodle 2 the completion settings of every activity should also influence the triggering behaviour of the review mode. I mean that if in the completion settings I set the completion to a specific grade or to the simple "must obtain grade" and I've set the passing score, this should influence and determine the triggering of the review mode ...

              So, the question is:
              My scorm is composed of many scoes. Any of this learning object has a status so any of them can be incompleted or completed (in my case there are no passed/failed).
              Are you telling me that if one status of the learning object that compose the scorm package turns to "completed", then the scorm package can switch in review mode?

              cibot CiBoT added a comment -

              Moving this issue to current integration cycle, will be reviewed soon. Thanks for the hard work!

              danmarsden Dan Marsden added a comment -

              Hi Carlo - most SCORM packages I see report a single lesson_status - not a lesson_status per sco.

              There is nothing detailed in the SCORM 1.2 spec that defines how to deal with pacakges that return a lesson_status per sco and My understanding of the spec is that only a single lesson_status per SCORM package should be reported.

              Any scorm package with a lesson_status of "passed/completed/failed" is counted as a "Gradable" event and the attempt is closed. Any attempts to re-enter that attempt will result in Moodle passing "review" mode to the SCORM package.
              The bug found last week showed that in some cases when the lesson_status was "passed/completed/failed" - Moodle entered into review mode correctly but it did not allow a "new" attempt to be loaded - so using settings like "force new attempt" would not generate a new attempt but enter into the previous attempt under review mode.

              Moodle did not conform to the ADL SCORM 1.2 spec previously in all cases and did not enter correctly into review mode as required by the SCORM specification.

              The completion settings used as part of Moodle's core activity/course completion do not control how a single "attempt" in SCORM is managed - that is up to the SCORM spec and how it is implemented within the SCORM package itself and the other attempts management settings within the scorm settings page.

              hopefully that explains it a bit better.

              thanks,

              stronk7 Eloy Lafuente (stronk7) added a comment -

              Hey Dan,

              so this fixes an issue, but not exactly the case commented by Carlo (multiple scoes providing lesson-statuses), correct?

              About the fix... could you, plz, review the testing instructions. I cannot see a difference between 1) and 3), it should be more evident (missing "Single Activity Course format" detail?).

              I'll be happy integrating this once the points above are a bit more clear. TIA!

              danmarsden Dan Marsden added a comment -

              Thanks Eloy - 1/3 use a different setting for display method (current vs new window) - the code path is slightly different when managing new attempts.

              I think the issue Carlo is having is a combination of the bug that the fix addresses and a mis-understanding on how SCORM manages lesson_status and attempts. In any case if we confirm there is a different issue we can open a new bug. Thanks!

              stronk7 Eloy Lafuente (stronk7) added a comment -

              ah, thanks, lol, I read them 3 times and was unable to find the difference! Thanks for the clarifications.

              stronk7 Eloy Lafuente (stronk7) added a comment -

              Integrated (26, 27 & master), thanks!

              ccomincini Carlo Comincini added a comment -

              Hi Dan. I want to add some more informations:
              I've looked at the scorm debugger and now I've a very clear idea of what happens in sequence.
              My SCORM Package is made of a number of html files in which are loaded a swf video that contain the lesson's slides. These swf files call each one an external mp4 that contains the teacher's recorded video lesson. This is synchronized by the swf player with the sfw slides so that every X frames of the video, the swf movie is checked and the play status is set at the correct frame. In this way the slides are always in sync with the video and we can use a low res video and an hi-res slide (because into the swf the slides symbols, lines, fonts and so on are vectors)

              Now when the first lesson (html) is opened an onload action is triggered. This action triggers the doLMSInitialize and the check of the status of the sco.

              At the end of the movie the page is reloaded. There is an other action on the html that is trigered onbeforeunload or onunload, and this actions calls doLMSCommit and dLMSFinish and set the status of the sco.

              Here we have the issue:
              The SCORM has a grading based on the learning object count. To set the SCORM grade to "5" the student has to complete 5 lessons.. Every lesson is marked completed when it ends. We must set the lesson complete to get the grade of the scorm.
              A SCORM package made of 25 lessons will have 25 scoes completed.
              Into the Moodle database in the mdl_scorm_scoes_track table we will have three rows for each sco:

              the first row will mark the x.start.time, the value and the timemodified
              The second will record the cmi.core.lesson_status the value (incomplete/complete) and the timemodified
              The last will record the cmi.core.total_time its value and the timemodified
              And this will be for each userid, scormid and scoid.

              Now if i set the grading method on the learning-object status, the scorm can't be "completed" if the whole scoes are not in completed status or the student will get review mode at the middle of his attempt.

              Last but not the least: this scorm package worked correctly in the 1.9.x moodle version.
              The question is: why not in 2.X?

              danmarsden Dan Marsden added a comment -

              Looks like I've hijacked your tracker issue to fix a bug that is not directly related to the issues you are having (sorry about that!) - lets move this to a new tracker issue so we can continue discussion without affecting the patch proposed here - I've created MDL-45821 to continue this discussion further.

              lameze Simey Lameze added a comment - - edited

              Test passed, the SCORM works as expected in all tests.

              ccomincini Carlo Comincini added a comment -

              Simey...
              ..."i'd like to buy a vowel"...
              synthesis is a great asset, but some some more infos will be appreciated
              Thankyou.

              danmarsden Dan Marsden added a comment -

              hehe..

              Hi Carlo - we follow a process when including code changes in Moodle core - Simey's comment signifies the end of the QA component of the process and that the testing instructions added to this tracker issue succeed with the patch I have included. At the end of this week all bugs that have passed the QA process will be included in the weekly build...

              (although - it appears we might still have an issue that you are experiencing which hasn't been addressed so we'll do that as part of MDL-45821)

              ccomincini Carlo Comincini added a comment - - edited

              :-D
              GREAT! So we will continue in the new MDL-45821.
              Thankyou very much.

              stronk7 Eloy Lafuente (stronk7) added a comment -

              Nice to see your contributions coming, and coming, now that we are back to normality. Many thanks for all them!

              Normal is an illusion.
              What is normal for the spider
              is chaos for the fly.

              – Morticia Addams

              Closing as fixed, ciao


                People

                • Votes:
                  1 Vote for this issue
                  Watchers:
                  7 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    14/Jul/14