Moodle
  1. Moodle
  2. MDL-45904

Ability for other roles to add site-cohort to course

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Duplicate
    • Affects Version/s: 2.6.3
    • Fix Version/s: None
    • Component/s: Administration, Cohorts
    • Labels:
      None
    • Affected Branches:
      MOODLE_26_STABLE

      Description

      Teachers can not add site-cohorts to courses. The can add category-cohorts to courses.

      I have created a role Cohort enroller, see : http://docs.moodle.org/26/en/Cohort_enroller

      However, this role can once again only enrole category-cohorts, and I want them to have the ability to add site-cohorts to courses as well.

      I think this option should be made possible.

        Gliffy Diagrams

          Issue Links

            Activity

            Petr Skoda added a comment -

            hi, this is a duplicate of existing issue where new capability "use cohorts defined above this course" is proposed, I cannot find it right now, sorry.


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: