Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-4633

Profiles requires entry in Description field

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.5.3
    • Fix Version/s: 1.9.12, 2.0.3
    • Component/s: Administration
    • Labels:
    • Environment:
      All
    • Database:
      MySQL
    • Affected Branches:
      MOODLE_15_STABLE
    • Fixed Branches:
      MOODLE_19_STABLE, MOODLE_20_STABLE

      Description

      A constant annoyance in moodle is the fact that a students cannot make minor changes in the profile (like a change to the email address) without being forced to write something in the Description field. In other words, moodle won't let a student save the profile unless the student has filled in something in the Description box.

      It doesn't make any sense to force users to have to fill in a description as long as they can circumvent it by entering a dummy character, like a hyphen. As an administrator,it is annoying to have to keep explaining to users that the reason they can't save the profile is that they didn't enter a description.

      Please allow users to save the profile without having to enter a description of themselves in the profile.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              weinerk KW added a comment -

              temp workaround that worked for me:

              in this file:
              http://host/moodlepath/user/edit.php

              find this line:
              $mform->addRule('description', $strrequired, 'required', null, 'client');

              and comment it out like this:
              //$mform->addRule('description', $strrequired, 'required', null, 'client');

              trick Alan Trick added a comment -

              Yeah, I agree with this too. It's rather annoying and it results with a good number of user profiles ending up with retarded things like '.' in them. I don't see any good reason to require the field. I could make the change myself, but then I have to keep track of it which is a pain.

              medexnorthwest Medex added a comment -

              I had to edituser/edit_form.php
              line28
              $mform->addRule('description', 'required', null, 'client'); ///edit removed $strrequired

              and the user was not required to enter any data in the description field.

              ethan335 Ethan Cohen added a comment -

              I'd like to see this corrected as well.

              danp Daniel Phillips added a comment -

              Agreed with all of the above comments.

              This seems to be a useability issue. I would prefer if the description field was left as an optional field.

              sole2000 Hellmuth Sole added a comment -

              I also agree... I'm having the same thing happen on my website and ideally we would have some sort of option which would allow for admins to define what fields are required and which ones are optional.

              keoghs Sean Keogh added a comment -

              I see that this issue is currently assigned to nobody. Martin, I have a commercial client for whom this is an issue - no description is required when a user account is created, but as soon as a user visits their profile, they have to put something in...the field suddenly becomes mandatory.

              Is this a bug, or deliberately designed behaviour?

              Sean K

              mblake Michael Blake added a comment -

              Martin, can you please comment here. Is the requirement to enter something in the description field a bug or is they by design?

              dougiamas Martin Dougiamas added a comment -

              Well, it WAS by design. The idea was to encourage users to put something there, of course, to help others know who they were dealing with.

              However, I see this doesn't seem to often work as planned and it should be made optional.

              It's been planned for some time to convert a lot of these standard fields into custom fields (and thus editable per site) but this is a big job and still hasn't happened ...

              So a quick hack just removing the required status should be done anyway.

              rwijaya Rossiani Wijaya added a comment -

              Created patch to remove the 'required rule':
              1.9 diff patch: https://github.com/rwijaya/moodle/compare/MOODLE_19_STABLE...MDL-4633-m19

              2.0 diff patch: https://github.com/rwijaya/moodle/compare/master...MDL-4633_m20

              Thanks
              Rosie

              samhemelryk Sam Hemelryk added a comment -

              Looks good thanks Rosie +1

              rwijaya Rossiani Wijaya added a comment -

              Submitted to pull request:
              1.9: PULL-427
              2.0: PULL-428

              tsala Helen Foster added a comment -

              Thanks everyone for your comments and thanks Rosie for fixing this issue. The fix is available in this week's Moodle 2.0.2+.

              tsala Helen Foster added a comment -

              The fix is also available in the latest 1.9.11+.


                People

                • Votes:
                  25 Vote for this issue
                  Watchers:
                  14 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    5/May/11