Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-46400

Font color and background color buttons don't set the style at the current cursor position

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Duplicate
    • Affects Version/s: 2.7, 2.7.8, 2.8.6, 2.9
    • Fix Version/s: None
    • Component/s: HTML Editor (Atto)
    • Labels:
      None
    • Affected Branches:
      MOODLE_27_STABLE, MOODLE_28_STABLE, MOODLE_29_STABLE

      Description

      Using Chrome/Firefox with font color and background color button added to Atto toolbar

      Both buttons, when clicked, don't set the style at the current cursor position. For example:

      • i'm typing "this text going to be red"
      • select the color red in the fontcolor button
      • continue typing "this should be red" but it still black.

      You need to select the "this should be red" text and then select the color to actually change it. I thought there was a similar problem for bold and italic that was resolved since but I can't find the related issues in the tracker right now.

      In the end, font color and background color button should behave like bold or italic.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              jackdaniels JD
              Participants:
              Component watchers:
              Andrew Nicols, Jun Pataleta, Michael Hawkins, Shamim Rezaie, Simey Lameze
              Votes:
              3 Vote for this issue
              Watchers:
              5 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: